Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I love screen, but it drives me nuts that I have to stop typing input, hit CTRL+A [, and then find what I need.

Is there a way to make the scroll wheel function normally, rather than scrolling commands?

Also, is it possible to enable Shift+PageUp/PageDn?

share|improve this question
2  
Not an answer but tmux makes this much easier. I've tried to do this in screen before but it seems to always involve mapping arcane escape codes that vary by terminal emulator. – jw013 Jul 17 '12 at 1:08
    
aperiodic.net/screen/faq you probably just have to disable the alternate screen – Ulrich Dangel Jul 17 '12 at 1:52
up vote 9 down vote accepted
+100

I use these settings with urxvt in my ~/.screenrc:

termcapinfo rxvt-unicode ti@:te@
termcapinfo rxvt ti@:te@
termcapinfo rxvt 'hs:ts=\E]2;:fs=07:ds=\E]2;screen07'

Those allow for scrollbar and mouse wheel to do "the right thing™".

share|improve this answer
1  
+1. Using "xterm" instead of "rxvt" and "rxvt-unicode", Shift-PgUp/-PgDown work for me on gnome-terminal. But the mousewheel scrolls in the shell history. – daniel kullmann Jul 17 '12 at 7:24
    
when using gnome-terminal, mousewheel scrolls normal, i.e. in scrollback. – daniel kullmann Jul 17 '12 at 7:31
    
When I use screen in gnome-terminal. Don't worry about it... – daniel kullmann Jul 17 '12 at 7:38
1  
This also worked for me using xterm in place of rvxt*. Thanks! – Bryan Agee Jul 19 '12 at 18:24
    
Could you explain what each of these command do, please? – Totor May 3 '14 at 12:39

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.