Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am using the proprietary nvidia drivers in KDE (Debian Testing) and as many others experience issues with performance. I noticed that it gets a bit better if I run:

nvidia-settings -a InitialPixmapPlacement=0

at least with Google Chrome.

How can I add this to the standard start-up configuration? I tried adding an option to xorg.conf and I tried adding this line to a newly created .xinitrc, but it didn't work. Where should I have it added?

share|improve this question

1 Answer 1

up vote 2 down vote accepted

In ~/.nvidia-settings-rc, add a line (or change it, if it is there with a different value) like this:

0/InitialPixmapPlacement=0

and have

nvidia-settings --load-config-only`

executed on your session startup (some details). How to set this is desktop environment-dependent and only in the basic case (say, using a minimal or self-configured desktop environment) done via ~/.xinitrc.

I don't know about the details with KDE, but here's some blog post describing it, it's somewhere under system settings.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.