Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am facing problem with a facebook on linux these days, but when i switch back to windows (windows 7)it works absolutely fine.

I am using fedora 14, 64 bit machine with Mozilla Firefox 3.6.24. Even i tried to open facebook in opera browser the problem remains same.

Problems seen yet are:

  1. After login, the first page appears is not loading fully to see more stories.

  2. chat window is not appearing

  3. Any picture is not opening on clicking over it.
  4. Whenever i click on like button, it does not work.

I even tried : yum update firefox

No Packages marked for Update

Can anybody tell me what wrong is going on?

share|improve this question
3  
A facebook Unix / GNU Linux user? Who would've thought ;-) –  invert Jul 13 '12 at 8:01
1  
I've noticed the same behavior on my machine on Chromium. Strange.. –  minerals Jul 13 '12 at 11:44
2  
Does the same problem happen when using the same version of the same browser in the Windows install? This is more likely a browser issue and not an OS issue. Other than checking for the OS through the User-Agent and doing different things, there aren't that many ways an AJAX site can work differently across Windows and GNU/Linux –  njsg Jul 13 '12 at 14:14
    
Can you try with a more recent version of Firefox on a more recent distro? Fedora 14 and Firefox 3.6.24 are quite old. –  Renan Jul 13 '12 at 15:29
1  
That's normal, browser compatibility is difficult to archieve. –  warl0ck Sep 12 '12 at 0:47
show 2 more comments

2 Answers 2

FireFox 3 is old and busted, I recently battled with it in a site rewrite. There is quite a few HTML5/CSS3 things that are not fully or properly implemented. FB implements cutting edge web technologies such as HTML5 and CSS3.

I recommend building from source to get closer to a version near 10.0 or better.

share|improve this answer
add comment

I use Mageia2 64-bit with Firefox 10.0.5 and everything works perfectly. I am also using the latest Adobe version of their Flash player. So I would agree that the issue is with your browser (old) or, since you haven't stated, your version of Flash player (since Facebook is heavily flash oriented).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.