Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

On a daily basis, at around the same time each day (early morning and early afternoon), my computer stops being able to access google or any sites that use google code (including sites that use google adsense, google api, blogspot, youtube, google itself). This persists until I reboot my computer. I have a laptop on the same network, using the same router, which is able to access these sites just fine, but it's an old laptop and can only access the web in elinks so I want to use the internet from this computer instead.

Based on the output of mtr, I'm experiencing 50% packet loss, 16 hops in the direction of google. My best guess is that rebooting the computer causes it to take a different path to google, bypassing the node that's causing me trouble. Is there anyway to get it to do that without having to reboot?

Output of mtr:

 Host                                     Loss%   Snt   Last   Avg  Best  Wrst StDev
 1. [my isp]                               0.0%    43   13.8  14.4  13.2  21.1   1.2
 2. [my isp]                               0.0%    43   16.0  14.3  13.1  17.8   0.9
 3. 81.183.2.17                            0.0%    43   15.9  16.2  15.1  22.0   1.1
 4. 81.183.2.16                            0.0%    43   14.8  18.5  13.7  64.1  10.9
 5. 81.183.0.217                           0.0%    43   15.1  25.2  14.9  60.4  15.4
 6. 81.183.2.217                           0.0%    43   14.5  14.5  13.5  15.4   0.5
 7. 209.85.243.121                         0.0%    43   16.8  17.9  16.7  26.9   1.5
 8. 72.14.234.11                           0.0%    43   34.5  35.3  30.0  79.7  10.1
 9. 72.14.235.17                           0.0%    43   40.5  43.2  39.1  75.3   7.9
10. 72.14.235.174                          0.0%    43   40.0  45.0  39.4  78.3   9.1
    72.14.235.172
11. 216.239.43.4                           0.0%    43  112.0 116.5 111.2 135.7   7.1
    216.239.46.218
12. 216.239.46.217                         0.0%    42  147.5 150.9 146.4 188.7   7.4
    216.239.46.215
13. 72.14.232.141                          0.0%    42  155.5 161.4 155.2 203.8  12.5
    209.85.241.22
14. 216.239.46.52                          0.0%    42  165.7 169.2 164.9 200.9   7.3
    216.239.46.54
15. 216.239.46.241                         0.0%    42  245.8 195.5 190.6 245.8   8.2
    216.239.46.213                                                                  
16. 216.239.47.186                        51.2%    42  212.4 208.9 208.0 212.4   0.9
17. 72.14.233.140                          0.0%    42  210.6 479.9 209.0 11415 1728.
    72.14.233.138                                                                   
18. 64.233.174.97                          0.0%    42  213.0 477.7 208.5 11364 1720.
[cuts off here because my screen isn't big enough]

output of nslookup google.com:

Server:         208.67.222.222
Address:        208.67.222.222#53

Non-authoritative answer:
Name:   google.com
Address: 173.194.39.99
Name:   google.com
Address: 173.194.39.104
Name:   google.com
Address: 173.194.39.105
Name:   google.com
Address: 173.194.39.101
Name:   google.com
Address: 173.194.39.103
Name:   google.com
Address: 173.194.39.97
Name:   google.com
Address: 173.194.39.96
Name:   google.com
Address: 173.194.39.100
Name:   google.com
Address: 173.194.39.110
Name:   google.com
Address: 173.194.39.102
Name:   google.com
Address: 173.194.39.98

netstat -rn:

Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
192.168.1.0     0.0.0.0         255.255.255.0   U         0 0          0 eth0
169.254.0.0     0.0.0.0         255.255.0.0     U         0 0          0 eth0
0.0.0.0         192.168.1.1     0.0.0.0         UG        0 0          0 eth0

I had to reboot to ask this question because stackexchange uses google api too, but I'm sure I'll have the problem again later today, as I do every day. I looked at mtr again, and I'm getting no packet loss (as expected after reboot), and it doesn't take a path through 216.239.47.* which is the node that was giving me trouble.

share|improve this question
    
Is this specific to Google? Do you get the same IP address when you reboot? –  Gilles Jul 13 '12 at 23:25
    
@Gilles I have a dynamic IP address, but it doesn't seem to change every time I reboot (just checked it). It would probably change if I rebooted my router or if I disconnected and reconnected to the internet within my router's page. The problem is specific to google, but has been going on for over a year now so it's unlikely to be a local outage. Google owns half the internet so when I have this problem, I lose access to most of the web. Because it's not 100% packet loss, if I increase my timeouts in my browser, I can sometimes get a google hosted page to load with a lot of refreshes. –  Joshua Jul 14 '12 at 18:32
    
@Gilles For sites that are entirely on google's servers (google itself, blogspot, youtube), that's the best I can do. For sites like stackexchange that use google api, I can access them with limited functionality by adblocking ajax.googleapis.com/* and google's ad javascript. (On stackexchange with googleapi adblocked I can read but not comment/login/ask & answer questions) –  Joshua Jul 14 '12 at 18:37
    
This comment didn't notify dadinck, you need to leave it below his answer. These services shouldn't matter (but then your symptoms are unusual). The code for the ARP cache flush looks correct, are you sure you didn't make a typo? –  Gilles Jul 14 '12 at 19:23
    
oh, thanks; I've moved the comment. I might've made an error when I copypasted it earlier, so I'll try it again next time I have the problem. –  Joshua Jul 14 '12 at 19:40
show 1 more comment

3 Answers 3

You could try flushing out your DNS. You could set your DNS to 8.8.8.8 (google public DNS server). You might also clear out your arp cache.

for arptable in `arp | grep "eth1" | cut -d " " -f1`; do arp -d $arptable; done
share|improve this answer
    
Thanks for the link on flushing out my DNS. Unfortunately, my computer doesn't seem to have any of those services. The only services I have running right now (just after reboot) are openbsd-inetd, pulseaudio, saned, and winbind. I'll try restarting openbsd-inetd next time the problem occurs to see if that does anything. The code you gave for clearing my arpcache gave: bash: syntax error near unexpected token `do' –  Joshua Jul 14 '12 at 19:34
    
I figured out what I was doing wrong: i was typing sudo before that command and it gave me the error. I had to use sudo bash and then it worked fine. I set my DNS to 8.8.8.8 in my router and I've flushed my arp cache. Still no google unfortunately, but thanks for trying to help. –  Joshua Jul 16 '12 at 16:07
1  
to flush arp table just run ip neigh flush all to flush route cache ip r f c –  eicto Nov 11 '12 at 19:58
add comment

I ran into this problem as well, although not as frequently as every day.
Someone else who had a similar problem was told to disable IPv6 and it apparently worked: http://ubuntuforums.org/showthread.php?t=1528202
I'm trying to do that as well using more updated instructions from: http://www.noobslab.com/2012/05/disable-ipv6-if-your-internet-is.html
Let me know if this works for you or if you found a different solution.

UPDATE: It turned out that a defective router was causing the problem. Changing the router solved it for me.

share|improve this answer
1  
Beware. If you have to disable IPv6, then you will have to re-enable it later. And you should complain to your ISP. –  Michael Hampton Nov 12 '12 at 1:18
add comment

I've been having the same problem for a long time now and still couldn't figure out exactly why. Not only does it happen to my PC, it also happens to my mobile devices connected to the same network. Why is this happening?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.