Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I can't seem to see colors in links2 (text mode), even after playing with my TERM settings. The links2 manpage and README.Debian don't specifically address this issue. Also, command-line options like -html-t-text-color are not recognized in my links2. But I can start and see colors in graphics mode (-g).

My eventual goal is to convert HTML syntax-highlighted document (e.g. JSON or Perl, Javascript, etc) and display them in terminals using ANSI codes for colors.

My platform: Debian Wheezy+Sid AMD64. Terminal emulators used: Konsole (4.6.5). Colors (including 256 colors) work normal for other programs, including emacs and mc.

Any pointers? Thanks in advance. I don't mind using other text-based browsers which support color.

share|improve this question
Use elinks instead which supports 256 colours. – Stéphane Chazelas Apr 22 '14 at 15:15

If the binary doesn't support the flags advertised by the manpage, check if you are actually executing the right binary. Other links packages or the alternatives system may be interfering.

share|improve this answer
Yup, it's /usr/bin/links2 and not a symlink. I also built links 2.7 from source just now and it's the same thing (no color, no -html-t-text-color et al options recognized). – Steven Haryanto Jul 13 '12 at 14:17
-html-t-text-color also doesn't work here, regardless of -g / -no-g. But -html-g-text-color is accepted and -g/-no-g work fine. Using Debian/Sid-AMD64 with urxvt. – pepe Jul 13 '12 at 15:05

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.