Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am running SL6. During GNOME session, the wifi is connected as soon as I login, however the same does not happen until I login.

The situation further worsens in runlevel 3 where the wifi is not connected even after login. I have tried many solutions related to *wpa_suppliant* over the internet but none seem to help. It seems like it is an open bug in Fedora (which, I believe, is near-upstream for RHEL family).

Because I use the box in a headless manner and use it as NAT for other devices connected to it through ethernet, I would want it to be connected once it boots without logging in. Is there a solution?

share|improve this question
    
are you using network-manager? –  Ulrich Dangel Jul 12 '12 at 15:49
    
Yes, its part of Gnome and I am using it. –  User1241 Jul 13 '12 at 15:42
add comment

2 Answers

up vote 1 down vote accepted

If you are using network-manager make sure that the connection is Available to all users and that network-manager is executed - see http://docs.redhat.com/docs/en-US/Red_Hat_Enterprise_Linux/6/html/Deployment_Guide/ch-NetworkManager.html for more details.

If you don't want to use network-manager (the bug you referred to is only valid for interfaces files) have a look at http://wiki.centos.org/HowTos/Laptops/WpaSupplicant which should explain the necessary steps do setup a wireless connection with wpa an interfaces files.

share|improve this answer
    
Thanks! Your solution helped a lot and my problem, it seems, is solved. –  User1241 Jul 13 '12 at 16:26
    
The asker writes: “My problem was solved by the WpaSupplicant solution (the CentOS link provided above). However, the solution contained in the link has one step that requires editing ifcfg-wlan0 (or equivalent) file for your wireless. Such a file did not exists in network-scripts folder and therefore I skipped the step, yet everything works fine as expected.” –  Gilles Jul 13 '12 at 23:17
add comment

If you are using network-manager, I suggest switching to wicd instead. In my experience, network-manager seems to be designed mainly for graphical desktops. On wicd, it's much easier to manage wifi networks without graphical tools.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.