Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

In order for me to watch HD videos without tearing, I need to disable my Composite setting in xorg.conf

Section "Extensions"
    Option "Composite" "Disable"
EndSection

But I love my transparency, so, how do I enable and disable it without restarting X? (Preferably using command line)

share|improve this question

3 Answers 3

Use fusion-icon.

alt text

share|improve this answer
2  
Or use "metacity--replace" for turning off composite effects (and "compiz --replace" for turning them on) ;) –  user2648 Nov 23 '10 at 15:37

You can't disable an X extension while the server is running - the X protocol simply has no way to tell clients “Oh wait, that extension that I said you could use is no longer valid and you'll crash if you try to use it now.” All you can do is stop running whatever composite manager you're using (as suggested in @iamsid's answer).

share|improve this answer
up vote 1 down vote accepted

Found a better way to do it, just:

  1. Menu
  2. Settings
  3. Window Manager Tweaks
  4. Compositor Tab
  5. Uncheck "Enable display compositing"

I think this is better since it doesn't involve installing new application and it did help me prevent tearing when watching HD movies.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.