Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a computer running OpenSUSE 12.1, 64-bit, default install.

How it works currently:

  1. I turn on the computer
  2. It goes through the boot process
  3. At some point during boot, I am asked for password to decrypt an encrypted partition

The problem is there is a timeout on this prompt, so I have to sit next to computer and pay attention to what is going on.

How can I disable that timer, so I could for example turn the computer on and go away, and then return after 1 hour and still see this prompt?

share|improve this question
add comment

1 Answer

up vote 5 down vote accepted

Have a look at this Opensuse forum thread. It reveals that it's an issue with systemd's default unit timeout and not respecting the timeout setting in crypttab.

It also provides a workaround -- letting the initrd take care of it, with an /etc/crypttab entry like this (i.e. adding the initrd)

cr_sdb3         /dev/disk/by-id/ata-SHORTENED-part3 none       initrd

followed by rebuilding with mkinitrd.

Additionally, the author of the linked post filed a bug report.

share|improve this answer
    
Somehow I missed the execution of mkinitrd. Thank you a lot. –  greenoldman Jul 11 '12 at 16:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.