Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a Raspberry Pi and while its plugged into the network via ethernet, my setup works and I can connect to the static IP.

Today I bought a wlan adapter and after install it works great too... but only one thing. It will not start up by it self?

To get the wlan running I actually have to plug the LAN cable in for a few sec, then I can connect by its static IP. After the LAN cable is plugged in I can unplug it and connect to it wirelessly. How wierd is that?

I'm guessing something aint starting up? Before it notices the LAN cable and starts up the service?

My setup is:

auto lo
iface lo inet loopback

auto eth0
iface eth0 inet static
        address 192.168.1.50
        netmask 255.255.255.0
        gateway 192.168.1.1

auto wlan0
iface wlan0 inet static
        wpa-ssid <ssid>
        wpa-psk <key>
        address 192.168.1.51
        netmask 255.255.255.0
        gateway 192.168.1.1
share|improve this question
1  
I'm not aware if (and if, how) the R-Pi's Debian image diverges from the "ordinary" GNU/Debian; but if it doesn't, have a look at the handbook entry on configuring network devices and the (more detailed) Debian Reference chapter for configuring (wireless) networking devices. –  sr_ Jul 10 '12 at 14:14
2  
The problem is probably that you are defining two routes to the same subnet and the kernel tries to answer via the lan interface. Try to disable/comment the eth0 option or specify/use another network for testing. –  Ulrich Dangel Jul 10 '12 at 17:10
1  
@ephsmith We probably won't get many because of this –  Michael Mrozek Jul 10 '12 at 20:19
    
@MichaelMrozek, that's what I get for ignoring Area51 for a month. –  ephsmith Jul 10 '12 at 22:40
add comment

1 Answer

up vote 2 down vote accepted

I use a similar set on a system I use as a server, having both wired and wireless connections to the LAN, same routes, different IP's (although it'll work with identical IP's, it confuses the heck out of ssh and whatnot.)

Try changing the

auto eth0

to

allow-hotplug eth0

which only makes the eth0 settings active when a cable is sensed in the jack. At the moment, you're enabling BOTH NIC's at the same time, and like someone mentioned, it may be a routing issue.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.