Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

At work, I would like to use KDE's dolphin as a file manager. However, our home directories reside on an AFS share [1]. When starting dolphin, it becomes unresponsive for dozens of minutes.

stracing it reveals that it tries to open all the nodes in our AFS tree:

openat(AT_FDCWD, "/afs/somewhereElse.tld", O_RDONLY|O_NONBLOCK|O_DIRECTORY|O_CLOEXEC

I need to stop dolphin from doing that; this behaviour makes the program completely unusable on AFS trees. Is there some setting that controls this?


[1] If you have never worked with AFS before, for the sake of this question, assume that there is a root directory that has subtrees from different universities, research institutes etc. mounted below it. The data in those subtrees really reside at the remote sites, so access is slow and resource-intensive.

share|improve this question
    
I thought the whole point of AFS is to use caching to make this not a problem. –  Mechanical snail Jan 2 '13 at 3:38
add comment

2 Answers 2

While this doesn't completely solve the problem raised here, there is an option called -dynroot-sparse in the OpenAFS client these days, which tries to reduce the number of directories that are visible under /afs. That can help avoid processes from trying to traverse all AFS cells in the world just by reading the directories in /afs (but it doesn't prevent anything from traversing everything in your local cell). See afsd(8).

KDE stuff just really needs to detect networked filesystems, and default to not traversing the whole thing (many programs do similar things, just by detecting certain filesystems like AFS, NFS, sshfs, etc). Here is a bug about this general issue, if you want to raise this there: https://bugs.kde.org/show_bug.cgi?id=178678. It sounds like this is still a problem.

share|improve this answer
    
This is probably a good temporary solution. The -dynroot-sparse option (described here: docs.openafs.org/Reference/8/afsd.html) was created specifically to deal with situations like this. –  jsbillings May 11 at 1:22
    
I doubt that I can get our AFS admins to enable this flag for our huge cell just to let me check it out, but thanks for the pointer! –  jstarek May 15 at 8:57
1  
@jstarek To be clear, this flag only needs to be specified on a client machine; for example, your workstation. If you don't have administrative access to that machine, then yeah, they might need some convincing; but it's a pretty common option for desktop-y machines, and it could be a good idea to turn on anyway. –  adeason May 30 at 0:47
add comment

Do you have previews enabled? I know that my system reads the current directory, and one level deeper to be able to show the cute mini-icons on the folders indicating the contents. Turning this off should help.

Does this happen on EVERY start of dolphin? or just the first one? The system may be building the file-system cache by reading things. Although I'm not sure why it would read the ENTIRE structure. Do you have some sort of indexing software running?

share|improve this answer
    
While disabling all preview functionality helped (thanks for that hint), the folder tree view (F7) still seems to try to open all folders. I don't quite understand this, since the first level of directories below the AFS root is cached locally and can be displayed without noticable delays in all other programs. –  jstarek Jul 6 '12 at 7:58
    
It's probably the folder-tree-view that's causing the delays, apparently it wants to enumerate the ENTIRE tree so it can display it quicker/easier. Hmmm. Ok... Now I know what to look for. –  lornix Jul 6 '12 at 8:00
    
Are you quite sure Nepomuk and Soprano (and Akonadi) are not running? Check under "Desktop Search" in "System Settings". That can grind a system to a halt, especially over networked filesystems. May need to log out/in after deselecting that. –  lornix Jul 6 '12 at 8:24
    
Sorry for the late reply, I didn't see your comment here. Both systems are turned off. –  jstarek Aug 15 '12 at 10:52
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.