Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

in my Debian stable, when I execute:

startx

as normal user the Xorg server begin to work, but after some second I recive in console this error:

FreeFontPath: FPE "/usr/share/fonts/X11/misc" refcount is 2, should be 1; fixing.

(I cut the stacktrace :))

When I execute Xorg as root, I haven't got this error!

I tried to:

  1. change permission in same file ->useless;
  2. reinstall XOrg -->useless
  3. file config not existing? -> what?

I have see the doc in the Net but I found the root of the problem: for you, what's (better, what can be) the problem?

EDIT:

my /var/log/log.0 ---> http://pastebin.ca/1998075

share|improve this question
1  
Do you have only this error message repeated many times, or do you have other messages as well? Does X crash (it's not clear from your question)? If X crashes, upload /var/log/Xorg.0.log somewhere (e.g. on pastebin.ca) and add a link to your question. –  Gilles Nov 21 '10 at 15:40
add comment

1 Answer

No one ever found the cause of this error, nor any actual problems caused by it, so it was resolved in later Xorg releases by simply removing the printing of the message.

share|improve this answer
    
another resolved in this way: chmod =s -vR 1777 / tmp (forum.debianizzati.org/viewtopic.php?f=18&t=24470 in Italian language). I executed this command and, after startx, I receive an "unable to connect to X server) :) In this link somebody say to download the .deb by Ubuntu and not by Debian :( –  alepuzio Nov 21 '10 at 18:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.