Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I increase my vlc sound more than 100% and after stoping or pausing vlc if I use clementine to play music the volume is same as vlc, i.e, more than 100% but in the indicator it shows whatever the previous set state, is this a bug? if so bug of vlc/clementine/gnome-shelll?

using fedora 17, gnome-shell, latest vlc and clementine

share|improve this question
up vote 0 down vote accepted

As far as I know, VLC doesn't change IT'S volume. It changes SYSTEM'S volume. So it is not a bug, it's designed to be that way.

VLC -> Volume(GNOME) -> Speakers

Clementine -> Volume(Clementine) -> Volume(GNOME) -> Speakers

share|improve this answer
This isn't the case on my system. VLC adjusts its own volume, but flat-volumes causes the sink volume to be adjusted too. See my answer. – Anonymous Jan 28 '13 at 22:44

This is a "feature" of PulseAudio.

; flat-volumes = yes (default)
flat-volumes = no

Flat volumes raises the sink volume so that it is no less than that of the loudest application. For more information, see pulse-daemon.conf(5).

share|improve this answer

It is a bug I'm sure, as it increases the systems volume but doesn't decrease it.

To verify just set the volume to 30 in fedora, then set volume to 90 in vlc, check fedora's volume, it's the same, then set vlc to 50, check fedora, volume is still at 90...

share|improve this answer

I am unaware of how this works in-depth, but if you adjust the volume in the full-blown sound menu (at least for gnome), you'll find the system volume itself goes over 100%, and VLC adjusts system volume, not it's own (personally, I think it's simpler that way, though if it's a huge deal to you, I'm sure there's an option somewhere to adjust its volume relative to the system)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.