Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Sbopkg used to work on my computer untill the network admin started to make a compulsory for the user to use proxy before connecting to the Internet. So, when I tried to sync to slackbuilds, I'm getting these errors:

root@meh:~# sbopkg -r
Syncing with the remote repository into /var/lib/sbopkg/SBo/13.1.
rsync: failed to connect to slackbuilds.org: Connection timed out (110)
rsync error: error in socket IO (code 10) at clientserver.c(122) [Receiver=3.0.7]

Rsync reported a socket error which may be due to
a problem with the LINK value in sbopkg.conf.
(The repo's LINK is currently set to: slackbuilds.org::slackbuilds/13.1).
Please check your settings and try again later.
share|improve this question
have you told sbopkg to use the proxy yet? looks like it is trying to communicate directly. – phunehehe Nov 21 '10 at 13:31
I've tried exporting http_proxy and I believe the http_proxy setting is working since I can use wget but I think sbopkg uses rsync. – amree Nov 21 '10 at 14:04
Hello @amree could you vote on the proposal to add a Slackware site here on SE: area51.stackexchange.com/proposals/74486/… – LnxSlck Jul 22 '14 at 15:06
Just registered, done :) – amree Jul 23 '14 at 8:37
up vote 1 down vote accepted

The rsync docs suggest:

You may establish the connection via a web proxy by setting the environment variable RSYNC_PROXY to a hostname:port pair pointing to your web proxy. Note that your web proxy's configuration must allow proxying to port 873.

Have you tried that?

share|improve this answer
tried exporting rsync_proxy=someproxy:someport and I'm still getting the same error, how do I check if my network allow 873 port? – amree Nov 22 '10 at 3:28
Note that environment variables are usually case-sensitive, so rsync_proxy is not the same as RSYNC_PROXY. To see if it works, I'd try connecting to a public rsync URL with rsync. Strictly for testing, try this: mkdir test ; rsync -avzH --delete msync.centos.org::CentOS test – Thomas Themel Nov 23 '10 at 16:36
Just tried and I got "bad response from proxy -- HTTP/1.0 403 Forbidden". I guess it's blocked, thanks for the guide. – amree Dec 1 '10 at 1:50

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.