Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a script that runs a calculation and then plots the result using gnuplot script file. The problem is that I need to make more than one plot and I don't want windows to cover each other. I tried this:

time ./run nano.lua
killall gnuplot
gnuplot -geometry -100-100 -p -e 'load "pqpss.plt"'
gnuplot -p -e 'load "pqpsss.plt"'

turns out that the -geometry option doesn't do anything. I'm tunning lxde with ubuntu 11.10.

share|improve this question
    
I don't want to use multiple plots within gnuplot because I can't easily resize them –  kirill_igum Jul 1 '12 at 21:06

1 Answer 1

Seems this might be a known bug: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=599129

Workaround suggest explicitly adding -display :0.0 (substituting your display as necessary):

$ gunuplot -geometry -100-100 -display :0.0 -p -e 'locat "pqpss.plt"'
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.