Sign up ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

Whenever I try to install or update a package using yum, after it updates its DB these messages are shown:

Loaded plugins: langpacks, presto, refresh-packagekit, tidy-cache google64
[Errno 14] curl#6 - "Couldn't resolve host" Trying other mirror.
[Errno 14] curl#6 - "Couldn't resolve host" Trying other mirror.

Error: failure: repodata/repomd.xml from mypck: [Errno 256] No more mirrors to try.

I'm running Linux 3.4.3. What could be causing this problem? How do I fix it?

share|improve this question

3 Answers 3

up vote 2 down vote accepted

The mirrorlist contains an invalid entry. On my Fedora installation, the error is simply informative as it goes to the next entry in the mirrorlist and completes successfully.

You can remove the error by (as root or using sudo) editing the file /etc/yum.repos.d/fedora-updates.repo. You will see the following lines:


Uncomment the baseurl line and comment out the mirrorlist line. This removes the option of getting updates from the maintained list of mirrors.

share|improve this answer
sorry , I can't vote up because I don't have enough reputation.thank you – M0εiπ Jun 29 '12 at 18:56
removing some repositories helped me, I am just using fedora.repo and fedora-updates.repo , it's working well now. – M0εiπ Jun 29 '12 at 19:02
@MoeinFatehi You can accept the answer, which gives you reputation so you can upvote in the future. – uther Jun 29 '12 at 19:09

Seems to me that the host just does not exist:

$ host
Host not found: 3(NXDOMAIN)

So, either

  1. wait until the host becomes available again
  2. find a replacement host and update that to yum sources
  3. remove the host from the sources

Note that

$ host is an alias for has address has address has address has IPv6 address 2001:4178:2:1269::fed2 has IPv6 address 2610:28:3090:3001:dead:beef:cafe:fed4

which may be what you are looking for.

share|improve this answer
would you please tell me how to remove or change it? – M0εiπ Jun 29 '12 at 15:47

This is how I fixed the issue. This will be help you

For me this issues occur because of the IPV6 internet connection in the Fedora. So first we have to disable IPV6 totally. here what you have to do

  • Open Terminal
  • Type su and enter to log in as the super user
  • Enter the root password
  • Type cd /etc/modprobe.d/ to change directory to /etc/modprobe.d/
  • Type vi disableipv6.conf to create a new file there
  • Press Esc + i for insert data to file
  • Type install ipv6 /bin/true on the file to avoid loading IPV6 related modules
  • Type Esc + : and then wq for save and exit
  • Type reboot to restart fedora
  • After reboot open terminal and type lsmod | grep ipv6
  • If no result, it means you properly disabled IPV6

Fedora may user your ADSL router or Modem as the DNS server. In other way Fedora may uses some less powerful DNS server for look-up. So your DNS look-up will be slow and wrong most of the time. This will cause to Curl errors and slow loading errors. So we have to set some powerful DNS server for look-up purpose in Fedora. Here is the steps.

  • Open Terminal
  • Type su and enter to log in as the super user
  • Enter the root password
  • Type cat /etc/resolv.conf to check what DNS server your Fedora using. Mostly - this will be your Modem IP address.
  • Now we have to Find a powerful DNS server. Luckily there is a open DNS server - maintain by Google.
  • Go to this page and find out what are the "Google Public DNS IP addresses"
  • Today those are and But in future those may change.
  • Type vi /etc/resolv.conf to edit the resolv.conf file
  • Press Esc + i for insert data to file
  • Comment all the things in the file by inserting # at the begin of the each line. Do not delete anything because can be useful in future.
  • Type below two lines in the file

    nameserver nameserver

  • Type Esc + : and then wq for save and exit

  • Now you are done and everything works fine (Not necessary to restart).
  • But every time when you restart the computer your /etc/resolv.conf will be replaced by default. So I'm let you find a way to avoid that.

Check here for the details answer

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.