Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I try to install subversion from source, but on ./configure receive:

configure: error: no suitable apr found

I have download apr source and installed:

libraries have been installed in:

So I returned to configure of subversion but receive the same error. What I should do? Thanks.

share|improve this question
up vote 5 down vote accepted

When configuring Subversion, try

./configure --with-apr=/usr/local/apr/

That might not be exactly the right path. Try finding apr-config and giving the path to that. I'm guessing it might be:

./configure --with-apr=/usr/local/apr/bin/apr-config

Try ./configure --help to see what your options are. There are a lot of them.

share|improve this answer

Have you tried including the path to LD_LIBRARY_PATH? I don't know how good an option this is, but something simple like this is worth a try:

export LD_LIBRARY_PATH="${LD_LIBRARY_PATH}":/usr/local/apr/lib
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.