Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

So I have been in the process of installing a Postfix Server on my CentOS 6.2 Virtual Private Server.

I have been following this tutorial:

http://www.howtoforge.com/virtual-users-and-domains-with-postfix-courier-mysql-and-squirrelmail-centos-6.2-x86_64

Because, I have never set up a Mail Server before..

So everything has worked fine up until the 5th page.

I am on step 15. It shows how to verify that Postfix is ready for SMTP-AUTH and TLS, but when I run the commands:

telnet localhost 25

and get:

Trying ::1...
Connected to localhost.
Escape character is '^]'.
220 server1.example.com ESMTP Postfix

So I type:

ehlo localhost

I get:

250-server.cdevelop.info Hello localhost [127.0.0.1], pleased to meet you
250-ENHANCEDSTATUSCODES
250-PIPELINING
250-8BITMIME
250-SIZE
250-DSN
250-ETRN
250-DELIVERBY
250 HELP

So there is no:

250-STARTTLS
250-AUTH PLAIN LOGIN
250-AUTH=PLAIN LOGIN

Which by the guide, and common sense, shows that it isnt ready for SMTP-AUTH nor TLS.. Everything has been installed in the Guide, and cofigured the way stated, but I am still getting this problem..

Would someone Kindly help me work this out? What should I be looking into? either configurations, or verify packages are installed or Error logs, etc.?

Is there anymore information I should provide to you folks?

Or just anything else anyone would like to say about this that may help my situation.

And if you cant provide any help or information, would someone mind pointing me to some good tutorials on setting up a lightweight mail server on my CentOS VPS? I really like the tutorial I am following now, because it allows Virtual Domains and Virtual Users, making it lighter, and more customizable. So if I could integrate virtual users and domains into another tutorial that would work too. :)

Thanks guys. Hope Someone could help out. Take Care.

share|improve this question

1 Answer 1

Just to be certain, double check you main.cf (/etc/postfix/main.cf on my Ubuntu distros not 100% sure for CentOS) and make sure that you have:

smtpd_sasl_auth_enabled = yes
broken_sasl_auth_clients = yes

I am by far not an expert in MTAs, but I have at least gotten far enough into to get mine to give me the AUTH and AUTH= responses and those two lines are what give you those results.

Just in case you are curious, from what I have been able to glean from reading guides and such, the smtpd_sasl_auth_enabled = yes line enables the AUTH {mechanisms} line of the response telling compatible clients that the authentication mechanisms are available. Make sure that you didn't leave off a letter somewhere like the 'd' in 'smtpd'. The broken_sasl_auth_clients = yes is to give the AUTH={mechanisms} response which I only skimmed that part and saw something about 'unsupported', 'clients' and 'outlook', then rolled my eyes and muttered a few choice words involving Microsoft.

Now for the STARTTLS stuff, I may not be 100% useful on that because I haven't yet tested TLS, since I am still working on transmitting mail on my server. I receive mail fine and courier authenticates IMAP users, but my Cyrus-SASL auth is failing the SMTP. I will do my best here and tell you I know the settings I have for it are:

smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

smtp_tls_security_level = may

I am afraid that all I can tell you about that is, again, make sure that you didn't miss a letter or an '_' where needed and check and make sure you haven't commented out a setting. As someone who is stumbling through postfix/mysql/cyrus-sasl/courier-imap(-ssl)/pam configuration and has stumbled through other configurations before, I can tell you I've done that more times than I care to admit to.

There are probably many many more qualified people who could better assist you further, but I beat them here when I started this, so hope it helps and happy stumbling.

share|improve this answer
    
Okay, FINALLY got mine authenticating via cyrus-SASL, so now I'm 100% up and running and I hope that I can help you do the same. –  txpeaceofficer09 Jun 22 '13 at 18:06

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.