Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

So my boss who hates the idea of windows and virtualization had brought me his fancy new Zenbook UX32VD wanting openSUSE 12.1 to be installed on it. SO far I have hit issue after issue and cant seem to find a lot of information on the problems I have encountered and I figured what better place to start collecting it then right here.

Laptop Manual

First issue I ran into when installing 12.1 on a Zenbook is there is no disc drive. I solved this by making a bootable USB drive.

Second issue I ran into is that the installer doesn't seem support the USB 3.0 ports on the Zenbook. Fortunately USB 3.0 is backwards compatible so I had to create another bootable USB on a 2.0 USB with openSUSE 12.1's Installation data.

Third issue I hit is a black screen after the installer loads udev; screen just completely goes black and nothing comes back up. It looks like the drives are still busy and loading is going on in the background but nothing happens. I think this is the optimus technology making openSUSE choke so I figured using VESA mode would take care of it..NOPE! Instead for some reason using the installation parameter nomodeset in the openSUSE boot menu works which is strange because to my understand nomodeset is the same as selecting VESA. Maybe I'm wrong? but nomodeset works for installation.

Fourth issue I ran into is that there are no drivers to support the Intel wifi in the stock installation of 12.1. In addition to this issue; there are no ethernet ports. Instead Asus has included a usb to ethernet adapter and I cant find out the spec on it; perhaps its not working because it USB 3.0 Ethernet adapter? cant find out and its not working.

Fifth (Major Issue!) After then install I'm already in a pickle because I cant update due to the connectivity issues I'm dealing with in the above issue. The biggest problem is however that after my install is completed and I reboot from the KDE desktop It boots straight int the system BIOS! The drives are detected by the BIOS and listed in the SATA configuration but there are no boot options and no options to set boot options. All I get is delete boot options. This is a real issue because all the work I have done up to this point is gone and for any alternative to installation I try requires me to repeat this installation process.

I'm stuck here and humbly need the help of the community! Thanks for reading this post and a big thanks in advance for any help contributed to accomplishing this install!

share|improve this question
3  
I stopped reading after the second issue that you managed to solve. This is not a blog. For the issues that you haven't solved, please open new questions: 1 issue per question. Thanks. –  dotancohen Jun 28 '12 at 19:13
    
while this is my first post to this Unix and Linux section of the stack exchange I am not new to the stack. TO inform you the stack exchange is a collection of 83 Q & A sites that are all aimed towards developing solutions. This thread contains unresolved issues along with useful information that might assist others one day facing the same problems unified under one topic. Please refrain from posting comments unless they are helpful. –  Wylie Coyote SG. Jun 28 '12 at 19:29
3  
You are right, there is some useful information in the post. You could post the first two issues as questions and then answer your own question. But grouping all the questions in a single thread is not the SE way of doing things, this is not a mailing list. I mentions this for your benefit, because I happen to want you to get the answers that you need. –  dotancohen Jun 28 '12 at 19:33
    
These issues are specific to the Asus Zenbook UX32VD Installation of openSUSE 12.1, and at this point your strategy is a matter of opinion. If you were really trying to help answers happen here you'd stop neging the thread. That way users that actually read from top to bottom might actually be able to provide some real assistance . –  Wylie Coyote SG. Jun 28 '12 at 19:38
    
Even if you find @dotancohen's comment to be rude, he has a point. I'm looking for a tl;dr: at the bottom of your post. Just start with one question and make it clear and concise. If people need more background, they'll ask for it. Hopefully someone can help you troubleshoot then. Hey I've been downvoted and heckled for crappy questions before, but c'est la vie. –  Banjer Jun 28 '12 at 19:44

1 Answer 1

up vote 0 down vote accepted

Have you tried, or are aware of NDISwrapper?

Excerpt from OpenSuse wiki:

Some vendors do not release specifications of the hardware or provide a Linux driver for their wireless network cards. The NDISwrapper project implements Windows kernel API and NDIS (Network Driver Interface Specification) API within the Linux kernel. A Windows driver for wireless network card is then linked to this implementation so that the driver runs natively, as though it is in Windows, without binary emulation.

More on the OpenSuse page.

share|improve this answer
    
Spot on Tim! this something I have never heard of! thanks for reading and helping me out! –  Wylie Coyote SG. Jun 30 '12 at 18:25
    
Glad to help! Happy Suse'ing! –  Tim Jul 1 '12 at 13:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.