Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

How to disable KDE system sounds? I mean all sounds on startup, on dialog box popup, on error and so on, without turning off the actual media sound.

I use KDE 4.7.4

share|improve this question
up vote 5 down vote accepted

In KDE 4.10.5, you can disable all system sounds without muting all media.

System Settings > Common Appearance and Behaviour > Application and System Notifications > Manage Notifications > Player Settings > No audio output.

Also, you may disable Event Sounds: left click the sound tray icon and slide down the Event Sounds slider or completely mute it.

enter image description here


In KDE Plasma 5, you can left-click the kmix (volume) plasmoid, and turn down "Event Sounds", similarly to the screenshot above.

If this doesn't work, you can turn off the sounds for each notification class individually, in System Settings > Notifications. Cycle through Event source, looking for entries with the Play a sound icon associated with the entry, then toggle off Play a sound.

share|improve this answer
    
Thanks! For me, it was a little surprising that the event class is not application-specific. If anyone wants to disable kwrite/kate sounds (and I guess many other generic applications), uncheck all Play a sound options with Event Source Plasma Workspace. – phihag May 31 at 10:57

There is a longstanding bug in KDE to disable sounds for all apps. I suggest commenting on that bug.

share|improve this answer

Try either:

System Settings -> Notifications -> Player Settings\

Then choose "No audio output."

or:

System settings -> General -> Notifications -> System notifications -> Applications -> Event source

Then choose"KDE System Notifications"

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.