Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have a 2010 iMac 27" as well as a 27" Apple Cinema Display. The iMac will auto-dim on inactivity, I'd say around 5 minutes. When the iMac dim's the Cinema Display is still bright. There is no "Automatically reduce the brightness of the display" option in Energy Saver or Displays within System Preferences. Anyone any suggestions?

CLI commands would be preferred.

share|improve this question
    
This probably belongs on http://apple.stackexchange.com instead. –  bahamat Jun 28 '12 at 6:01
    
Yes it does. At first I saw ask dif and was like wtf is that, that's not what I want. They should have just calle it Mac or apple :p –  mikemackintosh Jun 28 '12 at 11:38
add comment

closed as off topic by bahamat, Renan, jasonwryan, rahmu, Mat Sep 22 '12 at 15:00

Questions on Unix & Linux Stack Exchange are expected to relate to Unix or Linux within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer

For the Apple displays most of the tighter controls goes through USB - do you have the cable going from the display to the iMac?

Under display preferences do you see a checkbox for automatic ambient control, or for keyboard controls depending on versions. Try toggling these checkbox(es) and see if that affects the auto-dim.

Last but not least, ensure the dim buttons on your keyboard affect both main screen and the cinema display.

Awhile ago others had similar issues

https://discussions.apple.com/thread/2649213?start=0&tstart=0

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.