Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have this issue with Lenovo Thinkcentre Edge. Its keyboard has Fn key, which acts in my Ubuntu (with Fluxbox) as if it is always "active/pressed".

I can't use standard F1-F12 keys unless I hold down this stupid key. You see, I'm a programmer so it's really pain to me.

So I decided to remap function keys with xev and xmodmap

I remapped F1-F3 and 'till this point everything is fine, but F4 does some kind of window minimization. When I run xev and hit F4, I don't get a reply from the program with a keycode and stuff, instead the window is minimized and when I maximize the window again there is no response from the key.

Important info: The function of Fn key can't switched in bios.

So the question is: Do you have ANY idea how to solve my mystery?

EDIT:

# content of .fluxbox/keys
# click on the desktop to get menus
OnDesktop Mouse1 :HideMenus
OnDesktop Mouse2 :WorkspaceMenu
OnDesktop Mouse3 :RootMenu

# scroll on the desktop to change workspaces
OnDesktop Mouse4 :PrevWorkspace
OnDesktop Mouse5 :NextWorkspace

# scroll on the toolbar to change current window
OnToolbar Mouse4 :PrevWindow {static groups} (iconhidden=no)
OnToolbar Mouse5 :NextWindow {static groups} (iconhidden=no)

# alt + left/right click to move/resize a window
OnWindow Mod1 Mouse1 :MacroCmd {Raise} {Focus} {StartMoving}
OnWindowBorder Move1 :StartMoving

OnWindow Mod1 Mouse3 :MacroCmd {Raise} {Focus} {StartResizing NearestCorner}
OnLeftGrip Move1 :StartResizing bottomleft
OnRightGrip Move1 :StartResizing bottomright

# alt + middle click to lower the window
OnWindow Mod1 Mouse2 :Lower

# control-click a window's titlebar and drag to attach windows
OnTitlebar Control Mouse1 :StartTabbing

# double click on the titlebar to shade
OnTitlebar Double Mouse1 :Shade

# left click on the titlebar to move the window
OnTitlebar Mouse1 :MacroCmd {Raise} {Focus} {ActivateTab}
OnTitlebar Move1  :StartMoving

# middle click on the titlebar to lower
OnTitlebar Mouse2 :Lower

# right click on the titlebar for a menu of options
OnTitlebar Mouse3 :WindowMenu

# alt-tab
Mod1 Tab :NextWindow {groups} (workspace=[current])
Mod1 Shift Tab :PrevWindow {groups} (workspace=[current])

# cycle through tabs in the current window
Control Tab :NextTab
Control Shift Tab :PrevTab

# go to a specific tab in the current window
Mod4 1 :Tab 1
Mod4 2 :Tab 2
Mod4 3 :Tab 3
Mod4 4 :Tab 4
Mod4 5 :Tab 5
Mod4 6 :Tab 6
Mod4 7 :Tab 7
Mod4 8 :Tab 8
Mod4 9 :Tab 9

# open a terminal
Mod1 F1 :Exec x-terminal-emulator

# open a dialog to run programs
Mod1 F2 :Exec fbrun

# volume settings, using common keycodes
# if these don't work, use xev to find out your real keycodes
176 :Exec amixer sset Master,0 1+
174 :Exec amixer sset Master,0 1-
160 :Exec amixer sset Master,0 toggle

# current window commands
Mod1 F4 :Close
Mod1 F5 :Kill

# open the window menu
Mod1 space :WindowMenu

# exit fluxbox
Control Mod1 Delete :Exit

# change to previous/next workspace
Control Mod1 Left :PrevWorkspace
Control Mod1 Right :NextWorkspace

# change to a specific workspace
Control F1 :Workspace 1
Control F2 :Workspace 2
Control F3 :Workspace 3
Control F4 :Workspace 4

#osobni
Mod4 d :ShowDesktop
Mod4 m :Maximize
Mod4 f :Exec firefox
Mod4 u :Exec unison-gtk
Mod4 e :Exec eclipse
Mod4 t :Exec thunderbird
Mod4 q :Exec qutim
Mod4 s :Exec skype

Ubuntu is 12.04 LTS, kernel

3.2.0-23-generic #36-Ubuntu SMP Tue Apr 10 20:39:51 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
share|improve this question
    
Check your BIOS for a setting to toggle the Fn key behavior. –  jw013 Jun 26 '12 at 11:05
1  
Unfortunately, most BIOSes don't allow Fn behavior to be changed in any way. Your symptoms don't look like a problem with the BIOS though: the BIOS wouldn't know how to minimize a window. It looks like Fluxbox has mapped F4 to minimizing a window. Please post your Fluxbox configuration, and also tell us what Ubuntu release you're using. Do you see the same symptoms on a new account with no Fluxbox configuration? What about with other window managers? –  Gilles Jun 26 '12 at 21:55
    
I know it is not BIOS issue, I just mentioned it, because BIOSes on Lenovo notebooks allow to switch the function on Fn key. -> I'll edit original post and add what u asked for. –  xholicka Jun 27 '12 at 8:40
    
@Gilles Most laptops come with extra functions on the F1-F12 keys for actions like suspend, toggle wireless/touchpad, multimedia/volume control keys, that are accessed by holding down Fn. I've seen many laptops that have a BIOS option to choose whether the physical key registers as F1-F12 or the extra function, since a lot of end users don't use the F1-F12 keys. Thinkpad Edge's even do this by default (you need Fn-F1 to get F1). What I meant was if this is the case, finding the BIOS option would be much easier than trying to remap each F1-F12 key individually. –  jw013 Jun 27 '12 at 13:18

4 Answers 4

On Lenovo Thinkpad Edge, press Fn+Esc and Fn key will light up and you can use F1-F12 keys as default.

share|improve this answer

It's a bios option. Look for 'enable media keys' or 'enable function keys'. Often it's worded differently, dig around. Honest, it's there.

It's nothing to do with your OS, as this would be happening regardless of what you're running. The bios toggles a bit-switch somewhere and the keyboard firmware uses that to determine if a Fn-F1 is F1 or something else.

Unfortunately, the vendors have decided we need to be playing music more than we need to be using F-keys as selectors. Logitech keyboards do this too, and there's a way to flip their 'default state' as well.

share|improve this answer
1  
Man, like I stated before, there is no possibility to change this in BIOS. I literaly checked every single one setting in bios -> it can't be switched there. I'm sorry. –  xholicka Jul 17 '12 at 7:34
    
Can you indicate which BIOS option is that? I did not find it either. –  tml Sep 19 at 8:55
    
thinkcenter is not a laptop, the bois option you mention is for laptops. –  switch87 Nov 20 at 17:45

If it was a laptop Lornix would be right, my lenovo has this BIOS-option, but on a desktop it's inside the keyboard, I have the same problem with my keyboard. It is possible there is software to switch the behavior of the keyboard, search on google with the model number of the keyboard, not the computer. If you can't find it, take a look at the source for my keyboard, it may get you on the right road? here is the source: logitech k290

share|improve this answer

Press Fn + Num Lock to disable it.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.