Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have recently started using Arch with nvidia driver (I had a lot of problems getting nouveau to even work so I decided to try nvidia) and I started experiencing rather odd problems. Every now and then, at random, the screen starts displaying grid over all windows. Screenshot

Dock (cairo-dock) seems to be unaffected: Screenshot

I am running Arch 3.4.3-1 (x86_64) with Compiz-Fusion and Cairo-Dock under Gnome 3.4.1. Nvidia was installed using nvidia package in [extra]

Name           : nvidia
Version        : 302.17-1
URL            : http://www.nvidia.com/
Licenses       : custom
Depends On     : linux>=3.4  linux<3.5  nvidia-utils=302.17
Conflicts With : nvidia-96xx  nvidia-173xx
Architecture   : x86_64
Description    : NVIDIA drivers for linux.

Window manager is Emerald. Graphics card is GT220.

There is nothing relevant in the log (that I can see). The only way (that I found) to solve this is restart X server.

I would appreciate any help - I have been trying to find any way to solve this but haven't had any luck.

EDIT: I have been using gnome-shell for past 45 minutes and it hasn't crashed yet. Could it be a problem with compiz/emerald?

EDIT: Nope, sadly gnome shell experiences the issue as well. However it turns out that youtube videos are unaffected.

EDIT: Downgrading to 295.59 seems to have solved the problem.

share|improve this question

closed as off-topic by terdon Nov 11 '15 at 15:39

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions describing a problem that can't be reproduced and seemingly went away on its own (or went away when a typo was fixed) are off-topic as they are unlikely to help future readers." – terdon
If this question can be reworded to fit the rules in the help center, please edit the question.

Looks like a problem with your compositor... – jasonwryan Jun 25 '12 at 0:43
That pattern looks like the background indicating alpha transparency. Perhaps there's a problem with libpng. – Kevin Jun 25 '12 at 0:45
The same thing has just happened with gnome-shell. libpng is in version 1.5.11, never had any problems with it - how can I check if that's causing the issue? @jasonwryan: As I only just found out, gnome-shell has the issue as well. Am I right thinking that this implies it's not compositor dependant? – norfavrell Jun 25 '12 at 3:48
Try changing the gamme correction value. You can use "xgamma" binary for the same. – SHW Jun 25 '12 at 6:11
@SHW: Thanks for your suggestion - sadly it didn't help :( It looks like youtube videos are unaffected so it must be something to do with compositor. Any ideas how that could be solved? – norfavrell Jun 27 '12 at 10:34

I suspect this is a question for an arch Linux forum, I suspect you have (found) a driver bug. If appropriate, Arch linux can then escalate to nVidia.

Can you try installing an older nvidia package, or maybe arch linux has multiple packages for the nvidia driver (stable/updated/patched/...)?

share|improve this answer
How did this old question get on my radar?... – DutchUncle Jan 28 '15 at 16:17
Thanks for your response - I haven't ever solved the problem and in fact I still have that PC sitting untouched in my room somewhere. I'll upgrade it (surely 3 years worth of updates is not gonna cause any problems) and see if the problem still exists :) – norfavrell Jan 29 '15 at 8:38

Not the answer you're looking for? Browse other questions tagged or ask your own question.