Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

When I launch tmux in the terminal, is causes my Linux Mint to play a sound in the speakers.

The sound is a Linux Mint system sound. Perhaps it's the "alert" sound, but I cannot identify it by name.

The same alert sound plays when I exit tmux.

Any ideas on how to disable this sound when tmux is launched?

share|improve this question
1  
Do you have any of the bell settings in your .tmux.conf? –  jasonwryan Jun 24 '12 at 7:00
    
No, my .tmux.conf file is empty. –  eoinoc Jun 24 '12 at 9:59
    
I am seeing the same issue, after having enabled/setup the bell in general. It only happens with gnome-terminal, and there's an additional string when exiting tmux: ]112[exited]. tmux 1.9-6ubuntu1. gnome-terminal 3.6.2-0ubuntu1. Ubuntu 14.04. –  blueyed Oct 17 at 3:58

3 Answers 3

up vote 2 down vote accepted

Try setting either bell-on-alert [on | off] (off) or bell-action [any | none | current] (none). There's visual-bell [on | off] also.

share|improve this answer
    
Dang, none of them made a difference. For example, I set set-option bell-on-alert off in ~/.tmux.conf. –  eoinoc Jun 24 '12 at 15:51
    
@eoinoc, oh, it does, alas. :) –  poige Jun 24 '12 at 16:28
    
@eoinoc, It's really annoying issue looking like a bug, actually… –  poige Jun 26 '12 at 14:31
    
Oh, interesting if that's a tmux bug. –  eoinoc Jun 27 '12 at 17:33

The "bell" is launched by your terminal, not tmux! I use Gnome terminal and could disable it going to EDIT --> Profile Preferences and unticking "Terminal Bell" (this disable all the bells though)

share|improve this answer

This appears to be a bug in gnome-terminal.

I've just upgraded to 3.14.0-1 (from Debian testing) and the beep during startup and exit of tmux in gnome-terminal is gone.

Therefore it's likely to have been fixed since 3.6.2-0ubuntu1 - or there's an Ubuntu patch causing it (which Linux Mint might also use).

share|improve this answer
    
Nice one, thanks for sharing. –  eoinoc Nov 12 at 10:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.