Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This blog post talks about how to change the default application to handle a file type in Nautilus for individual file types (right-click on the file, "open with", and select the new default application), but is there a way to list all current associations and configure them in one go, similar to the Windows "folder options | file types" tab? There seem to be a bunch of default associations that I want to change (all various image files are being opened in IceWeasel instead of the image viewer), and I don't want to have to change them one-by-one in the file manager. If there's no GUI for doing this, then where does Nautilus store its file associations? Can I edit them with a text editor?

share|improve this question

All of your file associations are stored in $HOME/.local/share/applications/mimeapps.list. Some of them are not in your personal mimeapps.list file. There's a system wide file with all the default associations in /usr/share/applications/mimeapps.list and/or in /usr/share/applications/defaults.list.

For more info check out Specifications/mime-actions-spec

In Fedora 14 I have these settings files:

share|improve this answer
Thanks, that helps a little in that I do indeed have a $HOME/.local/share/applications/mimeapps.list with a few added associations, however I do not have any .list files in /usr/share/applications/ and yet there are evidently a bunch of other default associations stored somewhere. Do you know where else they could be stored? – Jez Jun 22 '12 at 14:31
More strangeness. I've looked through all the defaults.list and mimeapps.list files on the system, and in two of them, JPEG images are actually configured to run with eog.desktop which should open them in the image viewer and not Iceweasel, and yet Nautilus still opens JPEG images in Iceweasel. How could it be getting this file association? – Jez Jun 22 '12 at 15:04
That is strange. I have this: $ cat ./.local/share/applications/mimeapps.list | grep jpeg image/jpeg=gthumb.desktop;gnome-eog.desktop; – slybloty Jun 22 '12 at 15:47

On my system (Debian Jessie) I found all the normal methods of specifying a default application wouldn't override the one hiding in ~/.config/mimeapps.list.

Thunar insisted on opening a particular file with gedit even after I told it to make the correct application the default. When I removed the setting from ~/.config/mimeapps.list, it started working properly again.

share|improve this answer

I am using Ubuntu 13.10.

The file you need to edit is /etc/gnome/defaults.list.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.