Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I copied this this file (vokabel_daemon.service)

[Unit]
Description=Start vokabeltrainer daemon
After=network.target

[Service]
ExecStart=/home/mm/lib/vokabeltrainer/box_vokabeltrainer.pl daemon --listen "http://*:3001"

[Install]
WantedBy=mulit-user.target 

to /etc/systemd/system/ (openSUSE12.1).

Then after a

systemctl enable vokabel_daemon.service
systemctl start vokabel_daemon.service

I could open my website.

But after a reboot it doesn't work any more.

systemctl status vokabel_daemon.service:

vokabel_daemon.service - Start vokabeltrainer daemon
          Loaded: loaded (/etc/systemd/system/vokabel_daemon.service; enabled)
          Active: inactive (dead)
          CGroup: name=systemd:/system/vokabel_daemon.service

After a systemctl start vokabel_daemon.service it is working again:

vokabel_daemon.service - Start vokabeltrainer daemon
          Loaded: loaded (/etc/systemd/system/vokabel_daemon.service; enabled)
          Active: active (running) since Thu, 21 Jun 2012 08:38:16 +0200; 1s ago
        Main PID: 2288 (perl)
          CGroup: name=systemd:/system/vokabel_daemon.service
                  └ 2288 perl /home/mm/lib/vokabeltrainer/box_vokabeltrainer.pl daemon --listen http://*:3001

What do I have to change so that I don't have to start the daemon by hand after a reboot?

share|improve this question
add comment

1 Answer

up vote 5 down vote accepted

Assuming this isn't a typo, the install section in your typo service file contains a typo. It should be, multi-user.target instead of mulit-user.target (multi vs. multi), e.g:

[Install]
WantedBy=multi-user.target 
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.