Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I can't boot my Linux Mint after installation of Windows. First I installed Windows and then installed Linux Mint with the option of "Install along with windows". But after I completed the Mint install only Windows is booting.

I have done some search on the web and found that installing Grub from the Live CD will help on this issue. I have done that also (but I'm not sure whether I have done this correctly). After that Windows is also not booting and I am stuck on this.

share|improve this question
    
If you are able to boot into Windows then have a look at C:\boot.ini. Increase the timeout to check whether you are booting from Grub or NTLDR. –  SHW Jun 20 '12 at 8:17
add comment

3 Answers

up vote 1 down vote accepted

This is the correct way to install grub2 from a Linux LiveCD/USB:

  • sdXY is your / Linux partition (e.g. sda1)
  • sdX is the hard-disk containing the linux partition (e.g. sda)
mount /dev/sdXY /mnt
mount --bind /dev /mnt/dev
mount --bind /proc /mnt/proc
mount --bind /sys /mnt/sys

chroot /mnt    
grub-install /dev/sdX
update-grub
exit # (Ctrl+D)

umount /mnt/dev
umount /mnt/proc
umount /mnt/sys
umount /mnt

reboot
share|improve this answer
    
Great. It works fine for me and I can able to boot both the OS :-) Thanks a lot. –  Sivanandam Jun 22 '12 at 2:36
add comment

As I understand, you need windows & linux mint get working together. First, find first configuration file(i mean grub.conf), which has working configuration for windows, copy config lines, after that install grub from Live CD, take working config for linux, add new lines to the first config, and replace it on your computer. This should work for you.

Please, if you'll have any problems see example here

share|improve this answer
add comment

The problem is that you installed Linux Mint first and then Windows. Windows overwrote GRUB with its its own bootloader and then GRUB is not in use anymore. It is easier to install Windows first and then Linux so that way your computer's bootloader is GRUB.

You have a few options:

  1. From Linux Mint Community Tutorial for installing Grub2 and configuration: Boot with a Linux Mint live-CD/live-USB and install grub2, letting Linux set up GRUB for you. Then you would boot into Linux Mint and run a terminal sudo update-grub

  2. Option to add Linux to Windows Bootloader: for instance, try EasyBCD which allows you to add Linux to the boot loader. It's proprietary but it is free for non-commercial use.

I have used both methods and they both work well. Personally I prefer to use Grub2 and configure and tinker it to my liking with different fonts and images and its open sourced.

share|improve this answer
    
Thanks for the reply. I have installed Windows (first) and Linux (Second). Also I have tried the tutorial that you mentioned to install Grub 2. But it doesn't works. –  Sivanandam Jun 21 '12 at 11:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.