Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

First, I am new to Arch Linux. I have installed Arch Linux on my system and now when I try to install something using pacman, it gives me an error that the key 'xxxxxxx' was not found.

I Googled and found out I should have run pacman-key --init.
Now when I run pacman-key --init, it seems to go on for ever. I waited for more than 45 minutes, but still no result. I think it has something to do with generating Entropy.

Any idea what is wrong?

share|improve this question

1 Answer 1

up vote 7 down vote accepted

Nothing is wrong. As the Arch Wiki notes:

For this initialization entropy is required. Moving your mouse around, pressing random characters at the keyboard or running some disk-based activity (for example in another console running ls -R / or find / -name foo) should generate entropy. If your system does not already have sufficient entropy, this step may take hours; if you actively generate entropy it will complete much more quickly.

You can read more about entropy in the Linux Kernel on Wikipedia.

share|improve this answer
    
I ran the ls -R / many times in another terminal session (while running pacman-key), but no result. –  John Smith Jun 20 '12 at 7:05
    
Try something else that generates IO; redirecting output to a file and editing in vi is what I did last time around... –  jasonwryan Jun 20 '12 at 7:10
    
I did ls -R / > somefile and then vi somefile. Then I deleted a line and wrote the buffer to the disk (dd and :w) repeatedly. It completed very soon! Thank you. –  John Smith Jun 21 '12 at 4:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.