Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

When I try to bundle exec I'm getting

You have already activated rake 0.9.3.beta.1, but your Gemfile requires rake 0.9.2.2. Using bundle exec may solve this. ...

I have rake, version 0.9.3.beta.1

I would like to have version 0.9.2.2

How do I switch to it?

I'm on Ubuntu11

share|improve this question
    
can clarify your ubuntu version ubuntu 11.04 or ubuntu 11.10? –  Aboobacker Mk Jun 19 '12 at 4:53
    
The latest version I see on rake.rubyforge.org, is 0.8.7. How did yo install 0.9.3.beta.1 –  bbaja42 Jun 19 '12 at 8:44
    
@bbaja42 There are many ways to get the dev version - it can be installed from github, for example. –  D_Bye Jun 19 '12 at 9:34
    
Hi Aboobacker Mk, it's Ubuntu11.10 –  Michael Durrant Jun 19 '12 at 11:21
    
Check out the Ruby Version Manager. rvm.io –  Shawn J. Goff Jun 19 '12 at 11:56
add comment

1 Answer

up vote 3 down vote accepted

Have you tried installing the required version with gem?

$ gem install rake --version 0.9.2.2
share|improve this answer
    
This worked. Furthermore I didn't need to 'remove' my 0.9.3.beta.1 I just installed 0.9.2.2 and it's now my new version. Now I can rake spec without bundle exec ! –  Michael Durrant Jun 19 '12 at 11:26
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.