Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I would like to use a socks5 proxy (with authentication) with some programs. I found proxychains. I installed this and added my proxyIP, port, user and password to /etc/proxychains.conf. A test like proxychains wget google.com failed (timeout).

proxychains wget google.com > ProxyChains-3.1 (http://proxychains.sf.net) --2012-06-18 17:15:37-- http://google.com/ Auflösen des Hostnamen »google.com«... 173.194.70.100, 173.194.70.101, 173.194.70.102, ... Verbindungsaufbau zu google.com|173.194.70.100|:80... |S-chain|--94.x.x.x:999--173.194.70.100:80-

The proxy works. I tested with proxyfire in winXP. What is the problem? Did I forget something? Do you know an alternative?

share|improve this question
    
Proxychains works for me. Are you sure you have the configuration correct? –  Tim Jun 18 '12 at 19:29
    
An excerpt from your conf file should help us more. Remember to black out passwords. –  Tim Jun 18 '12 at 19:29
    
my /etc/proxychains.conf: pastie.org/private/tugikvp66nwd5diku1yua –  blobb Jun 18 '12 at 23:02
    
The only difference I see between your setup and mine is I have the line proxy_dns uncommented. Unless you have a specific reason to have it disabled, give it a try with that line uncommented. –  Tim Jun 19 '12 at 13:46
    
hm now i get a different error "|DNS-response|: google.com is not exist" pastie.org/private/ook9yvk13nllbipyeeh3ta –  blobb Jun 19 '12 at 14:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.