Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

On my Arch linux (x86-64) I use default login prompt (agetty + login), then after login X is automatically started by bash profile. After an update this weekend the login prompt from both agetty and login is not displayed.

I tried

  1. putting --noreset --noissue to /etc/inittab:

    c1:2345:respawn:/sbin/agetty --noclear --noissue -8 -s 38400 tty1 linux

  2. putting read to /etc/rc.local

    actually I put echo "Press enter" before read, but it is not displayed as well

  3. disabling all modules and daemons in rc.conf

  4. disabling vga=... argument in /boot/grub/menu.lst

but nothing helped. Just after the processing UDev events messages are printed, something resets the screen and nothing is visible. Looking into /etc/rc.sysinit I found out that after udev, LOCALE is set and then systemd-vconsole-setup is called.

When I insert my login and password (nothing visible), X starts normally. Ctrl+Alt+F1 works after X is started, not before.

My graphic card is Intel X3100. I have intel-dri, xf86-video-i740, xf86-video-intel and lib32-intel-dri installed.

share|improve this question
    
Is your /usr on a separate partition? –  jasonwryan Jun 17 '12 at 18:00
    
@jasonwryan no, only /home is separated –  Dadam Jun 17 '12 at 18:06
    
Boot from a live image and look at pacman's log and see what was in that last update... –  jasonwryan Jun 17 '12 at 19:05
    
@jasonwryan I can login into the system, I just don't see the login prompt and anything I type. When X starts, it is all ok. In the pacman log there is nothing wrong, just something about cabalized packages, but I don't use haskell anymore anyway. –  Dadam Jun 17 '12 at 19:14
    
Your part is not default inittab from Archlinux I think, is it? Download initscripts package and do 'xzcat initscripts-2012.06.1-1-any.pkg.tar.xz | tar -xvf - "etc/inittab' and replace. archlinux.org/packages/core/any/initscripts –  Jiri Xichtkniha Jun 17 '12 at 19:52

2 Answers 2

up vote 4 down vote accepted

Your issue seems to be related to KMS. Try adding your video card module to your /etc/mkinitcpio.conf MODULES line and rebuilding your intitramfs.

See the Arch Wiki Intel page for more details.

share|improve this answer

I have the same issue with NVIDIA, setting nomodeset in kernel parameters fixed this problem in my case.

share|improve this answer
1  
This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. –  rahmu Nov 1 '12 at 10:10
2  
@rahmu: Not really. The nomodeset parameter sometimes does resolve the issue that was mentioned in the question. –  darnir Nov 1 '12 at 10:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.