Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

So my home directory does have a .bash_history file, but it refuses to grow any bigger for some reason. I've already changed the .bashrc settings to set the history size to 99999 and the history file size limit to something similar.

share|improve this question
    
Which settings did you change? How big does .bash_history get? Do you want a single history file for all sessions or several history files? –  Gilles Jun 16 '12 at 23:26
    
I just set export HISTSIZE=9999 and export HISTFILESIZE=999999. I want a single history file for all sessions. –  InquilineKea Jun 17 '12 at 0:51

1 Answer 1

Find this in .bashrc:

# Make bash append rather than overwrite the history on disk

# shopt -s histappend

and uncomment the second line!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.