Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I replaced Windows 8 with Linux Mint. After the installation had completed, I restarted only to face a black screen with missing operating system.

I thought the problem was with Mint so I decided to try Fedora. Again I got the same problem. How can I fix this problem?

share|improve this question
2  
During the install process are you wiping the drive clean, including removing existing partitions created by Windows? –  Tim Jun 15 '12 at 17:49

1 Answer 1

up vote 5 down vote accepted

This is usually caused by a stupid bios that checks the partition table for the MS-DOS boot flag, and if no partition has it, prints this message and refuses to boot. Run sudo fdisk /dev/sda and print the partition table with p. If no partition has the boot flag, then set it with the a command, and finally save and exit with w.

share|improve this answer
    
Can't argue with that. And this procedure has saved me periodically. Though I eventually just flagged the first partition of almost all drives as "bootable" (possibly to my own detriment). –  killermist Jun 15 '12 at 21:51
    
Thanks dude.That solved the problem. –  Sudhagar Sachin Jun 16 '12 at 11:28

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.