Sign up ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. It's 100% free, no registration required.

On a Fedora 17 system (i915 hardware) KMS works out of the box - and using the console (i.e. Ctrl+Alt+F2 etc.) is very framebuffer-like. To the point that scrolling through a man page or cat log-files is dog-slow.

How can I configure the console speed in general? Or can I increase the scroll-speed somehow?

share|improve this question

2 Answers 2

I used to use FB quite a bit with SuSE, Slack and Gentoo on laptops, and had a similar problem.

I appended video=vesafb:ywrap,mtrr:3 to my kernel boot parameters and would speed things up a bunch.

More on the Gentoo wiki:

share|improve this answer
A little more info what the parameters do, and why it speeds things up, is appreciated in case the remote website is down. – Pro Backup Mar 15 '14 at 23:56

One can also try to disable fbdev and run SVGATextMode (that works well on nVidia hardware) from init instead. It will give a native VGA-like text mode that is very fast, but modes are tedious to setup for good text quality with modern monitors and they have some limitations (font no more than 9 dots wide and 512 characters in it maximum).

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.