Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

A few hours earlier I bought a beaglebone (Ångström installed) and now I am trying to add nameserver 8.8.8.8 (google DNS) to /etc/resolv.conf. However when I open it with vim and try to add my nameserver, it gives me E21: cannot make changes, 'modifiable' is off. I changed permissions via chmod. (chmod u+rx /etc/resolv.conf and also tried chmod 777 /etc/resolv.conf) But nothing changed.

Then I tried

:set modifiable :set write

This time I can change but still getting: E382: Cannot write, 'buftype' option is set error.

What should I do?

Regards

share|improve this question

closed as too localized by Michael Mrozek Jun 12 '12 at 13:47

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Could you show output of command ls -al /etc/resolv.conf –  bbaja42 Jun 12 '12 at 9:25
    
The file might have special attributes; you can check with lsattr –  D3L05 Jun 12 '12 at 11:36
    
Cross-posted on AU and answered there; closing this copy –  Michael Mrozek Jun 12 '12 at 13:47

Browse other questions tagged or ask your own question.