Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to add germand spell checking to vim. So I set

:set spl=de_de spell

then there is a dialogue, where I can create a directory called .vim/spell. And then there is another question where I can download a .spl file. And again for a .sug file. But when I download both files I get an error

Fehler beim Ausführen von "~/.vim/spell/de.utf-8.spl":
E763: 'Word Characters' unterscheiden sich zwischen Rechtschreibwörterbüchern

But despite the error I can use the spell checking and even the suggestion works.

Also I could not :mksp my own .spl-file from myspell, cause it wouldn't read the .dic-file. And I deleted the spelldirectory and retried it. Nothing worked.

share|improve this question
up vote 3 down vote accepted

Debian wheezy:

sudo apt-get install vim-scripts # Needed for spell downloading script
sudo rm /usr/share/vim/vim73/spell/*.sug /usr/share/vim/vim73/spell/*.spl
sudo vim

now trigger downloading in vim:

set spell spelllang=en,de,OR_WHATEVER_LANGUAGE_YOU_WANT

et voilà, you will get perfectly working spell files for all users.

(If you only want them for the current user, skip the sudo before calling vim or, change the installation directory to /home/YOUR_USER/.vim/spell.)

share|improve this answer
Thanks, that really helped! So there seems to be a conflict between the already installed (Fedora Linux) en.spl or en.sug files with the downloaded german/spanish/… files. – erik Jul 9 '15 at 17:56

I had a similar issue (same errormessage) and I guess, it was due to a compatibility-problem. The spell files I used (installed in .vim/spell) were from an older installation of vim and when I updated vim, I got this error. I solved it by using the vim spell files provided by my distribution -- in my case Arch Linux

sudo pacman -S vim-spell-de
share|improve this answer
Unfortunately there is no such packet for ubuntu. – pirad Aug 27 '12 at 16:58
had the same message, this helped. when moving from ubuntu to arch I had simply copied my old spell files. after removing .vim/spell, the message disappeared. – ilprincipe Nov 23 '12 at 19:23

I had the same problem with a self-compiled Vim 7.3.729 on Windows/x64. As the spell files at http://ftp.vim.org/vim/runtime/spell/de/ haven't been updated yet, I solved this in the following way:

  1. download the Arch Linux package mentioned in skunk's answer from https://www.archlinux.org/packages/extra/any/vim-spell-de/
  2. Extract the spell files from the vim-spell-de-20120506-1-any.pkg.tar.xz file (7Zip can unpack them).
  3. Overwrite the 4 files de.{latin1,utf-8}.{spl.sug} in ~/.vim/spell/
share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.