Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I've setup public key authentication for ssh'ing into my university machine. However, it only logs me in on the local machine and doesn't give me Kerberos credentials which I need for accessing my network folder. This causes problems with tools like git.

Is there a way for me to automatically get Kerberos credentials when ssh'ing without having to enter my Kerberos password?

My client machine is OSX 10.6 and my university machine is Ubuntu 12.04

share|improve this question

1 Answer 1

up vote 5 down vote accepted

Kerberos will work only if you authenticate to Kerberos-enabled server by password. You can:

  • set up kerberos trust for the incoming user if the user is already authenticated by known realm;
  • enable GSSAPI forwarding of credentials on ssh client and server ('ssh -K', GSSAPIAuthentication for sshd), this would work if server and client belongs to the same kerberos domain.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.