Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Update: It seems that it has been automatically fixed, however the same applies whenever I try to sudo gnome-open or gksu gnome-open

Well, this is a really weird one. I'm currently running Mint 13 and I just installed all my apps, including Sublime Text 2 and Dropbox.

Whenever I click the dropbox icon, instead of opening the folder, it opens sublime, the equivalent of running sublime-text-2 <dropbox folder>. Initially I thought it was a Dropbox bug, but when I tried to run gnome-open ., sublime gets opened (twice) instead of a files browser.

What could be happening here? I get the same result by running mate-open ., altough both commands appear to be in the right directory:

~  » whereis gnome-open 
gnome-open: /usr/bin/gnome-open /usr/bin/X11/gnome-open /usr/share/man/man1/gnome-open.1.gz
~  » whereis mate-open
mate-open: /usr/bin/mate-open /usr/bin/X11/mate-open

Also, I tried uninstalling sublime and both commands now work as they should, but whenever I install sublime, the same happens!

Thanks for your time.

share|improve this question

The below solution worked for me.

Run mate-default-applications-properties from terminal (or the application to set your preferred applications).
Set the default application choices.
Click close.
You are done!.
Don't ask me how/why.

share|improve this answer
You're right. This is due to the fact that, for some reason, Sublime Text is set-up as a preferred application in the File Manager option. However, sometimes it's not enough to open your "Preferred Applications" window (although it's irrelevant whether you do it from the terminal or using a menu). In any case, in order to fix this issue, you can select Sublime Text as your preferred application in File Manager, click close, open again and then select File Manager. Finally, close and this insanity should be over. – Robert Smith Jan 6 '13 at 3:44

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.