Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm fairly new to linux and nmap. I'm using debian squeeze. I tried installing an SQL-injection script for nmap. I was able to successfully run a test scan agains my web server running Windows. However, I can't seem to tell the script to run an SQL-injection test on a certain directory. I tried the following commands, but none of them are scanning the directory I want to scan. I'm trying to scan http://some.url/TESTNMAP:

nmap --script=sql-injection 10.10.10.10 --script-args sql-injection.start=TESTNMAP/
nmap --script=sql-injection 10.10.10.10 --script-args start=TESTNMAP/

For some reason, the --script-help option is just not available, so I can't run:

nmap --script-help sql-injection
share|improve this question
    
Are you missing a leading /? Example: sql-injection.start=/TESTNMAP/ –  Tim Jun 8 '12 at 15:45
    
just tried that. no luck ask well. It keep on showing stuff at the root level. I even tried --script-args='sql-injection.start=/nmaptest/' –  Bajingan Keparat Jun 8 '12 at 15:53
1  
Assuming it is this script: nmap.org/nsedoc/scripts/sql-injection.html, the documentation seems to indicate that is just spiders a site, so it most likely ignores the provided path. –  Tim Jun 8 '12 at 17:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.