Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I'm running "Centos 6 64-bit" on a Virtual Private Server (VPS) (i.e. on the cloud).

When I issue this command: "yum install vnc-server wine xterm fluxbox vsftpd firefox vnstat"

I get some results that all seem to be fine except:-

(...)
"No package wine available."
(...)
"No package fluxbox available."
(...)

What is the problem? How can I solve it?

This is my first time to use CentOS, and I've rarely used linux (Ubuntu) at all.

Thanks in advance.


EDIT:

1) To download the package as instructed, I presume this is the way to do it:-

wget http://packages.sw.be/rpmforge-release/rpmforge-release-0.5.2-2.el6.rf.x86_64.rpm

Result (last line only):-

You have new mail in /var/spool/mail/root



2) I then executed this:-

rpm --import http://apt.sw.be/RPM-GPG-KEY.dag.txt

Result:-

You have new mail in /var/spool/mail/root



3) Then:-

rpm -K rpmforge-release-0.5.2-2.el6.rf.*.rpm

Result:-

rpmforge-release-0.5.2-2.el6.rf.x86_64.rpm: (sha1) dsa sha1 md5 gpg OK



4) After that:-

rpm -i rpmforge-release-0.5.2-2.el6.rf.*.rpm

Result:-

package rpmforge-release-0.5.2-2.el6.rf.x86_64 is already installed



5) Installing Fluxbox:-

yum install fluxbox

Result:-

No package flusbox available.
Error: Nothing to do
You have new mail in /var/spool/mail/root



Steps from http://wiki.centos.org/AdditionalResources/Repositories/RPMForge#head-f0c3ecee3dbb407e4eed79a56ec0ae92d1398e01

EDIT 2:- By the way, I did the following before all of this (as suggested in a tutorial):-

Copy & paste the following into the Extra.repo file:

[dag]
name=Dag RPM Repository for Red Hat Enterprise Linux
baseurl=http://apt.sw.be/redhat/el$releasever/en/$basearch/dag
gpgcheck=1
enabled=1

[kbs-CentOS-Extras]
name=CentOS.Karan.Org-EL$releasever - Stable
gpgcheck=1
gpgkey=http://centos.karan.org/RPM-GPG-KEY-karan.org.txt
enabled=1
baseurl=http://centos.karan.org/el$releasever/extras/stable/$basearch/RPMS/

[kbs-CentOS-Misc]
name=CentOS.Karan.Org-EL$releasever - Stable
gpgkey=http://centos.karan.org/RPM-GPG-KEY-karan.org.txt
gpgcheck=1
enabled=1
baseurl=http://centos.karan.org/el$releasever/misc/stable/$basearch/RPMS/

Save & exit. (Then:-)

# rpm --import http://centos.karan.org/RPM-GPG-KEY-karan.org.txt
# rpm --import http://dag.wieers.com/rpm/packages/RPM-GPG-KEY.dag.txt
# yum update
share|improve this question
    
Please add the contents of /etc/yum.repos.d/rpmforge.repo –  Tim Jun 8 '12 at 15:49

3 Answers 3

up vote 1 down vote accepted

For CentOS 5, the fluxbox package was available in the RPMForge repo. But the CentOS 6 version of the RPMForge repo does not currently include fluxbox. The EPEL (Extra Packages for Enterprise Linux) repo for CentOS 6 does include fluxbox.

rpm -ivh http://dl.fedoraproject.org/pub/epel/6/i386/epel-release-6-7.noarch.rpm
yum install fluxbox

wine does remain available from the RPMForge repo in CentOS 6.

share|improve this answer
    
I think I've done that! I tried -ivh -Uvh with the two repos, but it didn't work... anyway, it did work now. Thank you! –  wajed Jun 9 '12 at 2:58

The packages you are getting the warnings about do not exist in the standard CentOS yum repo. You will need some 3rd party repos. You will want to be careful when adding new repo's, the good repo vendors ensure packages do not break each other, however there is some sloppy repo's out there.

I recommend checking Elrepo and RPMforge repos first for the packages you are missing.

CentOS Wiki about 3rd party repo's: http://wiki.centos.org/AdditionalResources/Repositories/

share|improve this answer
    
Are the repos small in size? They took few seconds to install. I still get "No package wine available." and "No package fluxbox available." What can I do? EDIT: Oh, I forgot checking if they contain the packages. I'll see and report back. –  wajed Jun 8 '12 at 15:03
    
RPMforge contains fluxbox. I use rpm -ivh and -Uvh, and I still get "No package fluxbox available." –  wajed Jun 8 '12 at 15:08
    
If they are not in elrepo or rpmforge, check that CentOS wiki page for a list of other recommended repos. –  Tim Jun 8 '12 at 15:08
    
Assuming that you installed RPMforge, did you also enable it? Full directions are here: wiki.centos.org/AdditionalResources/Repositories/RPMForge –  Tim Jun 8 '12 at 15:10
    
I'll edit my initial question for clarity. –  wajed Jun 8 '12 at 15:13

The EPEL (Extra Packages for Enterprise Linux) repo for CentOS 6 includes fluxbox.

The new URL is:

http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm

So you need to:

rpm -ivh http://dl.fedoraproject.org/pub/epel/6/x86_64/epel-release-6-8.noarch.rpm
yum install fluxbox
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.