Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

My laptop has an Atheros AR9285 wireless card. By following the "Network Configuration" section in the Gentoo handbook I chose the ath9k module. The modules seem to be loaded correctly:

# lsmod | grep ath
ath9k                  72172  0 
ath9k_common            2345  1 ath9k
mac80211              146807  2 ath9k,ath9k_common
ath9k_hw              213153  2 ath9k,ath9k_common
ath                     8652  2 ath9k,ath9k_hw
cfg80211              112782  4 ath9k,ath9k_common,mac80211,ath

And the interface also shows up in ifconfig:

wlan0     Link encap:Ethernet  HWaddr 00:22:43:61:a2:f0  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

However, I cannot do a network scan:

# iwlist wlan0 scanning
wlan0     Interface doesn't support scanning.

And the interface doesn't seem to be recognized:

# iwconfig wlan0
wlan0     no wireless extensions.

What can I try to make it work?

PS: I also have Ubuntu on this laptop and wireless is working fine.

share|improve this question
add comment

2 Answers

up vote 2 down vote accepted

I got the solution on Gentoo Forums. It turned out to be a mis-configured kernel. Hope that helps anyone who has the same problem :)

Here is the kernel configuration that works (from the post that I linked to above):

[*] Networking support  --->
    -*-   Wireless  --->
        <*>   cfg80211 - wireless configuration API                                                                                                                  
        [*]     enable powersave by default
        [*]     cfg80211 wireless extensions compatibility
        [*]   Wireless extensions sysfs files
        <*>   Common routines for IEEE802.11 drivers
        <*>   Generic IEEE 802.11 Networking Stack (mac80211)
              Default rate control algorithm (Minstrel)  --->
        -*-   Enable LED triggers

Device Drivers  --->
    [*] Network device support  --->
        [*]   Wireless LAN  --->
            <*>   Atheros Wireless Cards  --->
                <*>   Atheros 802.11n wireless cards support
share|improve this answer
1  
You wanna add exactly which config options you changed? –  Tshepang Jan 26 '11 at 19:39
    
@Tshepang the config options is in the post I linked to, do I really have to duplicate it here? –  phunehehe Feb 1 '11 at 15:09
    
I'm interested only in the ones you changed --> "when I set this and that option to that and this, the problem got fixed". Don't make me read the whole thread :) –  Tshepang Feb 1 '11 at 15:49
    
@Tshepang The working configuration is already on the post I linked to (it is an anchor that links exactly to where the configuration is). Anyway I included that in the answer. –  phunehehe Feb 1 '11 at 16:42
    
I'm aware of the anchor. The point is, what were your initial settings? Did you lose them? –  Tshepang Feb 1 '11 at 18:25
add comment

If you use DE, it's better to use NetworkManager (description of configuring NM on Gentoo).

Otherwise, you need to edit the net configuration file(/etc/conf.d/net):

config_wlan0=("dhcp")
modules=("iwconfig")
preferred_aps=("WI-FI_NAME")
config_WI-FI_NAME=("dhcp")

and then run /etc/init.d/net.wlan0 start to start it.

share|improve this answer
    
I don't have a file named /etc/init.d/net.wlan0. I guess that's the problem –  phunehehe Nov 14 '10 at 15:47
    
Try this: cd /etc/init.d ln -s net.lo net.wlan0 –  Spider.Ch Nov 14 '10 at 15:59
    
It tries to work like an Ethernet interface (wait for carrier and time out). Still I am unable to do any scanning. –  phunehehe Nov 22 '10 at 16:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.