Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

When I try any other finger with:

%> fprintd-enroll left-index-finger
Using device /net/reactivated/Fprint/Device/0
failed to claim device: Not Authorized: net.reactivated.fprint.device.setusername

It doesn't work for me;

But if I don't specify finger (which uses right-index by default):

%> fprintd-enroll 
Using device /net/reactivated/Fprint/Device/0
Enrolling right index finger.

It works

Running on Arch Linux , and packages installed from aur:

fprintd 0.4.1-4
libfprint 0.4.0-3

UPDATE

%> fprintd-enroll -f left-index-finger
Using device /net/reactivated/Fprint/Device/0
Enrolling right index finger.
share|improve this question

2 Answers 2

up vote 3 down vote accepted

I think this is only supported as of fprintd 0.5.1: http://cgit.freedesktop.org/libfprint/fprintd/commit/?id=7eb1f0fd86a4168cc74c63b549086682bfb00b3e

When I build fprintd 0.5.1, the -f option does work correctly.

share|improve this answer
    
Yes, 0.5.1 works! –  warl0ck Sep 3 '13 at 15:56

From the fprintd man page:

fprintd-enroll [username]
and
-f finger
For fprintd-enroll, the finger to enroll

It looks like you are placing "left-index-finger" as the username. and the user left-index-finger is Not Authorized

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.