Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I installed Mint 13, 64-bit, Cinnamon, and have a Canon ImageClass MF4150 printer. I retrieved and installed the drivers. I added the printer and tried to print a test page. The message said "printing", then "printing completed." However, nothing printed.

I used the following commands to install drivers:

dpkg -i cndrvcups-common_2.40-2_amd64.deb

dpkg -i cndrvcups-ufr2-us_2.40-2_amd64.deb

Then I add the printer in Printer settings. I also add myself as an allowed user.

Then I tried printing a test page and got a message saying "Printing test page on MF4100 series". After about 2 seconds I get a message saying "Printing completed ..." but nothing prints.

What am I doing wrong?

share|improve this question
    
Does anything appear in the printing logs (/var/log/cups/error_log, perhaps other files in the same directory)? If so, please copy-paste everything that appears after your printing attempts. –  Gilles Jun 5 '12 at 22:39

1 Answer 1

Maybe a little late, but I'm offering a partial/experimental answer in the hope that other community members may provide concrete explanations. If you are willing to take the risk and experiment, perhaps it will work in your setup too.

I'm running Linux Mint 15 64-bit and had the same problem with my Canon MF4570dn. I installed version 2.70 of the 64-bit driver from Canon's website:

sudo dpkg -l | grep Canon
ii  cndrvcups-common  2.70-1  amd64  Canon Printer Driver Common Modules Ver.2.70
ii  cndrvcups-ufr2-us 2.70-1  amd64  Canon UFR2 Printer Driver for Linux

I had the exact same problem that the computer says “printing”, but nothing happens in the printer. After much frustration, I came across two sites that mentioned some 32-bit libraries are needed for the Canon drivers and suggest installing the following:

sudo apt-get install libc6-i386 ia32-libs lib32z1

I did this and my printer works. For reference, the sites are:

https://phpraxis.wordpress.com/2012/07/08/install-canon-mf4350-cups-printer-drivers-in-64-bit-ubuntu-linux/

http://ubuntuforums.org/archive/index.php/t-1427330.html

Note that the sites also mention some symlinking, but I did not need to do this (in fact, on Mint 15, the referenced folders did not exist on my machine).

I don't understand why I need to install 32-bit dependencies on a 64-bit driver package (it is not listed as a requirement in Canon's documentation), which is why I call this a partial/experimental answer.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.