Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

So I have a TL-WR1043ND router with OpenWrt 10.03 on it. I have clients connected to it through the LAN ports. My ISP provides me a /64 IPv6 block, and I'm using PPPoE authentication.

How can I configure this "average" set-up? (IPv6 day is coming! :) ) so that the connecting clients can use (visit sites over) IPv6 and IPv4 too? (no I don't want to use any tunneling)

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Have a look at the IPv6 HowTo on the OpenWRT wiki. It's a pretty good starting point. I'm not going to give a detailed guide here, but a point-form summary of the broad steps to take.

First, choose a static IPv6 address from the /64 block your ISP gave you, and assign that address to the LAN side of your OpenWrt router.

Next, install and configure radvd in OpenWrt, to advertise itself as the default route and DNS resolver to LAN clients (clients should be configured to use IPv6 Stateless Autoconfiguration, unless you prefer to use static IPs, or DHCPv6).

And finally, configure firewall rules (remember that there is no NAT in IPv6, so it is essential to have a stateful firewall to prevent outside hosts from initiating unwanted connections to hosts inside your LAN).

share|improve this answer
    
Can you please write down the exact iptables rules that is needed to forward IPv6 to the clients from the pppoe connection? –  gasko peter Jun 7 '12 at 10:24
3  
You don't need any ip6tables rules. You just need to enable forwarding: sysctl -w net.ipv6.conf.all.forwarding=1 –  bahamat Jun 7 '12 at 21:32
    
@gaskopeter: Scroll to the bottom of the HowTo guide I linked to. You should find a minimal set of ip6tables rules there that implement a stateful firewall. –  Steven Monday Jun 8 '12 at 0:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.