Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I have the following scenario on my Centos 6.2 server:

eth0 : has IP 192.168.50.10

eth0:5 : has IP 10.0.0.1

When I boot the system, everything is up and working. When I run: ifdown eth0:5 and after ifup eth0:5, I get this error: Error, some other host already uses address 10.0.0.1. After I run ifdown eth0:5, I can ping the 10.0.0.1 host, but I cannot connect to it via ssh (from the same host). Before of ifdown command, I can ping the 10.0.0.1 and connect to it via ssh (from the same host). If I type service network restart, everything is ok again.

Question: Can anyone infer why that behavior?

N.B. I don't have the NetworkManager installed, and I don't have another host with this IP on the LAN (10.0.0.1).

EDIT:

The result of $arp -na command:

? (82.208.147.126) at 00:07:0e:5c:99:26 [ether] on eth0

share|improve this question
    
add the output of 'arp -na'. Chances are that another host on the same network has the same address. In this case, change it. –  Aki May 31 '12 at 11:54
    
@Aki you are right I think, because when I ping the 10.0.0.1 after the ifdown run, the time is much grater than the previous one. Anyway, I changed the gateway of my server to another workable one, and the problem was not anymore. I think there were some routing conflicts. Thanks. –  artaxerxe May 31 '12 at 12:14
    
RHEL-like distros have arping in their networking scripts which checks if the IP is already used in LAN. This explains the error. –  Jiri Xichtkniha May 31 '12 at 21:20
add comment

1 Answer

There IS another entity using that IP.

You could use nmap -O 10.0.0.1 to find out what it is.

share|improve this answer
    
Is there a way to force to use already used IP address? Just to take it away from the interface that is using it? I have IPKVM in my nic1 and I wanted to disable it from inside Linux somehow so IPKVM wouldn't hang on public it. When the system is down or restarted the IPKVM would start working again as it's IP address is not overwritten by Linux? Or there maybe other ways? –  Ilia Rostovtsev Mar 20 '13 at 11:32
    
@IliaRostovtsev so that IP is in use on a different interface on your server? What is your nmap-output? What does arp -an|grep "10.0.0.1" show? You should not force an IP unless you really know what you are doing. –  Nils Mar 21 '13 at 10:05
    
Those commands show the presence of interfaces on current IP. Like I mentioned above, I just would like to try to shutdown RMM (IPKMV) that is set via server bios as a static IP address. If I could do that than I would stop IPKVM hanging in public before I restart my system or enter a command. Where could I read about taking an IP address. Or how could I try to do it? I actually thought it wasn't possible? –  Ilia Rostovtsev Mar 21 '13 at 10:32
    
@IliaRostovtsev the MAC-Prefix 00-07-0E is registered to Cisco Systems Inc.. This looks like a cisco-device - possibly a router, whose mac-address you see through eth0 (not ON eth0). Talk to your network-guys and get a free IP for your server. –  Nils Apr 10 '13 at 12:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.