Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I need to disable some parts in ACPI, but it is simply not present in kernel 2.6.38.8 (downloaded as a tar from net)?

I can see the option in kernel 2.6.34-12 (default on OpenSuse 11.3), but not in the other one.

What's the point that I am missing?

P.S. Screen shots are from kernel 2.6.38.8.

enter image description here

enter image description here enter image description here

share|improve this question

1 Answer 1

up vote 5 down vote accepted

The ACPI block depends on PCI being enabled.

Symbol: ACPI [=y]
...
  Depends on: !IA64_HP_SIM && (IA64 || X86 [=y]) && PCI [=y]

If you disabled PCI (or didn't enable it), or selected a different architecture, you won't see any options related to ACPI.

share|improve this answer
    
that's a great answer, thanks for that. –  TheIndependentAquarius May 30 '12 at 12:08
    
BTW, where did you find this written? Depends on: !IA64_HP_SIM && (IA64 || X86 [=y]) && PCI [=y] I can't see it in my screenshots. –  TheIndependentAquarius Jun 1 '12 at 6:07
1  
It's the help text for the selector... that is hidden if you don't have PCI enabled. –  Mat Jun 1 '12 at 6:11
    
Mat, thanks but that's not helpful on the part of kernel. :( –  TheIndependentAquarius Jun 1 '12 at 6:19
    
I think it might be accessible in 3.x kernels, but can't test right now. Kconfig is a bit quirky. –  Mat Jun 1 '12 at 7:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.