Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

After I install emacs package on Debian 7 (Wheezy), when I start it up on a GUI terminal, it opens a GUI (GTK-based). I would rather it just run from the terminal.

share|improve this question
    
Maybe it's aliased - see alias emacs, or maybe you should check for another command name: apropos emacs will give you a pointer. Also, see type emacs. –  Herman Torjussen May 28 '12 at 20:02

1 Answer 1

up vote 7 down vote accepted

You can start emacs with the --no-window-system command line option (-nw for short).

$ emacs --no-window-system

Debian also offers a package that has X disabled, emacs-nox. It Conflicts with the normal emacs23 package (the main one, which runs X when available). It removes the need to specify the --no-window-system option.

share|improve this answer
    
You can also do DISPLAY= emacs. With $DISPLAY unset, emacs just uses the terminal. –  Alexios May 28 '12 at 21:58
    
@Alexios good point .. that's one of the strengths of Linux/Unix, so many ways to accomplish tasks. –  Levon May 28 '12 at 22:04

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.