Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I am trying to load the bwn driver as a module as mentioned in the man page.

However, when I attempted to edit /boot/defaults/loader.conf I could not write the changes to the file, this was attempted as root.

Then I read that this file is not to be edited. How can I load this driver as a module?

share|improve this question

1 Answer 1

up vote 3 down vote accepted

You need to put if_bwn_load="yes" in /boot/loader.conf. If you don't have a /boot/loader.conf file on your system, just create it. As with the /etc/defaults/rc.conf file, /boot/defaults/loader.conf contains default values that can be overridden in a per-system fashion.

Of course, you'll need to either reboot the system to pick up the new setting, or load the module manually the first time with kldload if_bwn.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.