Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

On start-up, xfce4 loads lots of desktop pictures (I have the settings set to 'image list') one after another (about 10, but I have the feeling it gets more and more). That by itself would be no problem, but then it decides to show no background image, just an awful shade of brown. Plus, it shows files (icons) on the desktop, which I don't want.

Where could I start to look to fix it?

share|improve this question
    
have you tried reset the settings? –  phunehehe Nov 12 '10 at 17:02
add comment

2 Answers

To remove the icons:
right click on the desktop -> Desktop settings -> Icons -> Icon type -> None

share|improve this answer
    
no, that seems to get overriden –  pats Nov 14 '10 at 9:37
    
Could it be that there's Nautilus auto-starting? –  Joril Nov 14 '10 at 10:52
    
yes, but why should this cause problems? –  pats Nov 14 '10 at 12:59
    
Nautilus tries to handle the desktop, so it overrides xfdesktop :) Try launching Nautilus with --no-desktop –  Joril Nov 14 '10 at 14:09
    
no I don't have nautilus installed... –  pats Nov 14 '10 at 14:15
show 10 more comments

Did you directly install xfce, or did you start with something like ubuntu (which installed GNOME by default) then switch over to it?

If you have, boot into your other desktop environment, and try turning off all desktop settings there.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.