Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I performed:

$ ssh-keygen -t dsa -P '' -f ~/.ssh/id_dsa 
$ cat ~/.ssh/id_dsa.pub >> ~/.ssh/authorized_keys

then in /etc/ssh/sshd_config changed StrictModes to no and restarted sshd.

And I have:

$ ssh localhost
Agent admitted failure to sign using the key.
dev@localhost's password: 

What's wrong? How to make ssh localhost working without password?

UPDATE:

$ ssh -v localhost
OpenSSH_5.5p1, OpenSSL 1.0.0e-fips 6 Sep 2011
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: Applying options for *
debug1: Connecting to localhost [127.0.0.1] port 22.
debug1: Connection established.
debug1: identity file /home/dev/.ssh/id_rsa type 1
debug1: identity file /home/dev/.ssh/id_rsa-cert type -1
debug1: identity file /home/dev/.ssh/id_dsa type 2
debug1: identity file /home/dev/.ssh/id_dsa-cert type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.5
debug1: match: OpenSSH_5.5 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.5
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 none
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host 'localhost' is known and matches the RSA host key.
debug1: Found key in /home/dev/.ssh/known_hosts:16
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: Roaming not allowed by server
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey,gssapi-keyex,gssapi-with-mic,password
debug1: Next authentication method: gssapi-keyex
debug1: No valid Key exchange context
debug1: Next authentication method: gssapi-with-mic
debug1: Unspecified GSS failure.  Minor code may provide more information
Credentials cache file '/tmp/krb5cc_500' not found

debug1: Unspecified GSS failure.  Minor code may provide more information
Credentials cache file '/tmp/krb5cc_500' not found

debug1: Unspecified GSS failure.  Minor code may provide more information


debug1: Next authentication method: publickey
debug1: Offering public key: /home/dev/.ssh/id_rsa
debug1: Authentications that can continue: publickey,gssapi-keyex,gssapi-with-mic,password
debug1: Offering public key: /home/dev/.ssh/id_dsa
debug1: Server accepts key: pkalg ssh-dss blen 434
Agent admitted failure to sign using the key.
debug1: Next authentication method: password
share|improve this question
2  
Try running ssh -v localhost and paste here the output. Plus look for messages from sshd in /var/log/syslog, /var/log/messages and /var/log/auth.log. –  Marki555 May 27 '12 at 19:06
    
No /var/log/syslog|auth.log files on my system. /var/log/messages do not contain anything on this. –  Eugene Retunsky May 27 '12 at 19:39
    
Does either SSH_AUTH_SOCK=0 ssh localhost or ssh-add ~/.ssh/id_dsa.pub work? –  Ulrich Dangel May 27 '12 at 19:46
2  
FWIW, I always use two commands: 1. ssh-keygen -t rsa (or dsa), then 2. ssh-copy-id "username@hostname -p" for rsa. I don't usually use dsa, but I think the second command is something like ssh-copy-id -i /homedirectory/.ssh/id_dsa username@hostname -p. –  Marty Fried May 27 '12 at 20:32
2  
Check the permissions on $HOME/.ssh and the key files. –  James Youngman May 27 '12 at 22:49
show 4 more comments

2 Answers

Try setting the permissions on the ~/.ssh/authorized_keys file and the ~/.ssh/ folder:

chmod go-w $HOME/.ssh
chmod 600 $HOME/.ssh/authorized_keys
chown `whoami` $HOME/.ssh/authorized_keys

Source: http://www.openssh.org/faq.html#3.14

share|improve this answer
1  
Welcome to *nix SX. Although your answer is OK, please note that the permissions on ~/.ssh and its files are the problem has been suggested to be the cause of the problem in comments as well (James Youngman). It is good practise (IMHO) that if you improve on someones comment or answer, you give some credit in yours. –  Anthon Jun 7 '13 at 9:50
add comment

Add your public key to the authorized_keys.

share|improve this answer
2  
That was "cat ~/.ssh/id_dsa.pub >> ~/.ssh/authorized_keys" –  Michael Mrozek Jan 14 '13 at 1:51
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.