Take the 2-minute tour ×
Unix & Linux Stack Exchange is a question and answer site for users of Linux, FreeBSD and other Un*x-like operating systems.. It's 100% free, no registration required.

I bought new laptop Dell Inspiron and first thing I installed Linux Mint and Eclipse for Java development. But I didn't like the look of Eclipse, everything just looks too big on the screen. Half of the space is taken by the tabs and menus, no room for editor, also the font is too big.

I would like to shrink the whole screen if possible, to have smaller fonts and tabs etc., but the display is on the maximum resolution already (1366x768).

How can I do this? I'm quite new to Linux and gnome, but I'm sure there is a simple solution to my problem.

share|improve this question
    
Does the output of xdpyinfo indicate that you are using the screen resolution you expected? –  James Youngman May 26 '12 at 13:52
    
yes it shows correct resolution –  jyriand May 26 '12 at 15:28
    
And what about the reported physical screen size? (actually directly related to the screen resolution (pixel density, not pixel area), should be given along with the pixel area size in xdpyinfo; resolution/density being given in the resolution line). You may have an issue where the resolution is wrongly guessed, and even if it's correctly guessed, you may want to decrease it, so that the programs (at least the ones respecting this setting...) look smaller. –  njsg May 26 '12 at 17:25
    
actually I found the solution. here. stackexchange allows to post my own answer in a few hours. –  jyriand May 26 '12 at 17:35
add comment

2 Answers

up vote 2 down vote accepted

I found the solution here. It recommends creating a new compact GTK style by pasting this into ~/.gtkrc-2.0:

style "gtkcompact" {
GtkButton::default_border={0,0,0,0}
GtkButton::default_outside_border={0,0,0,0}
GtkButtonBox::child_min_width=0
GtkButtonBox::child_min_heigth=0
GtkButtonBox::child_internal_pad_x=0
GtkButtonBox::child_internal_pad_y=0
GtkMenu::vertical-padding=1
GtkMenuBar::internal_padding=0
GtkMenuItem::horizontal_padding=4
GtkToolbar::internal-padding=0
GtkToolbar::space-size=0
GtkOptionMenu::indicator_size=0
GtkOptionMenu::indicator_spacing=0
GtkPaned::handle_size=4
GtkRange::trough_border=0
GtkRange::stepper_spacing=0
GtkScale::value_spacing=0
GtkScrolledWindow::scrollbar_spacing=0
GtkTreeView::vertical-separator=0
GtkTreeView::horizontal-separator=0
GtkTreeView::fixed-height-mode=TRUE
GtkWidget::focus_padding=0
}
class "GtkWidget" style "gtkcompact"
share|improve this answer
add comment

Font sizing is not all controlled in one place. You should be able to control the fonts Gnome uses for the desktop environment by using the menu "System > Preferences > Appearance". There is a "Fonts" tab in the dialog box that comes up.

The font settings for Eclipse are under the menu item "Window > Preferences". In the dialog box, select "General > Appearance > Fonts and Colors".

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.